Bug 450711 - DVD fails to mount in F9, works in F7
DVD fails to mount in F9, works in F7
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 11:41 EDT by stanl
Modified: 2009-07-14 11:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 11:50:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stanl 2008-06-10 11:41:15 EDT
Description of problem:  DVDR is setup in Fedora 9 at boot, but when I try to
load a dvd of files, it gives an error.  Same harware and DVD works find in
Fedora 7.


Version-Release number of selected component (if applicable):
Not sure

How reproducible:  Every time.


Steps to Reproduce:
1.Boot Fedora 9 system
2.Put DVD in tray and close
3.Device not mounted, error occurs in dmesg
  
Actual results:  Device not mounted


Expected results:  Device shows up on desktop


Additional info:
The DVDRW is on the second channel of an IDE (pata) as master.  There is also a
CDRW on the same channel as slave.  While the DVDRW is recognized on boot in
Fedora 7, even there I have to do a soft reboot to pick up the CDRW.

These are the relevant boot messages.  Notice that the DVDRW drive is
recognized, then replaced by the CDRW drive later.  sr0 should be the DVDRW and
sr1 should be the CDRW.

SCSI subsystem initialized
Driver 'sd' needs updating - please use bus_type methods
libata version 3.00 loaded.
scsi0 : pata_amd
scsi1 : pata_amd
ata2: PATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xf008 irq 15
ata2.01: failed to IDENTIFY (I/O error, err_mask=0x1)
ata2: failed to recover some devices, retrying in 5 secs
ata2.00: ATAPI: DVDRW IDE 16X, VER A07R, max UDMA/66
ata2: nv_mode_filter: 0x1f39f&0x1f01f->0x1f01f, BIOS=0x1f000 (0xc6c7c5c0)
ACPI=0x1f01f (30:60:0x1f)
ata2.00: configured for UDMA/66
scsi 1:0:0:0: CD-ROM            DVDRW    IDE 16X          A07R PQ: 0 ANSI: 5
Driver 'sr' needs updating - please use bus_type methods
sr0: scsi3-mmc drive: 1x/48x writer cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.20
sr 1:0:0:0: Attached scsi CD-ROM sr0

These are the relevant error messages when I try to mount the DVD

Buffer I/O error on device sr0, logical block 1048501
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : Hardware Error [current] 
sr 1:0:0:0: [sr0] Add. Sense: Timeout on logical unit
end_request: I/O error, dev sr0, sector 8388016
Comment 2 stanl 2008-06-13 11:14:07 EDT
Experimenting with this.  When a DVD isn't recognized, it sometimes pops up a
dialog that says unable to read superblock.  Audio CDs come up saying disc
doesn't contain audio data.

Occasionally a dvd or cdr will be mounted.  Sometimes the files are available,
sometimes not.  
Comment 3 stanl 2008-06-16 17:02:06 EDT
Switched the CD and DVD to make CD master, DVD slave.  Seems to allow the boot
to recognize the drive every time.

Ran an strace as root while trying to mount the device.  Here is the last part
of the output, the mount command and resulting error.

mount("/dev/sr1", "/media/dvdr", "iso9660"...,
MS_MGC_VAL|MS_RDONLY|MS_NOSUID|MS_NODEV, NULL) = -1 EINVAL (Invalid argument)
rt_sigprocmask(SIG_UNBLOCK, ~[TRAP SEGV RTMIN RT_1], NULL, 8) = 0
open("/usr/share/locale/locale.alias", O_RDONLY) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=2512, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0xb80b5000
read(3, "# Locale name alias data base.\n#"..., 4096) = 2512
read(3, "", 4096)                       = 0
close(3)                                = 0
munmap(0xb80b5000, 4096)                = 0
open("/usr/share/locale/en_US.utf8/LC_MESSAGES/util-linux-ng.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en_US/LC_MESSAGES/util-linux-ng.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en.utf8/LC_MESSAGES/util-linux-ng.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en/LC_MESSAGES/util-linux-ng.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
write(2, "mount: wrong fs type, bad option"..., 119mount: wrong fs type, bad
option, bad superblock on /dev/sr1,
       missing codepage or helper program, or other error) = 119
write(2, "\n", 1
)                       = 1
stat64("/dev/sr1", {st_mode=S_IFBLK|0660, st_rdev=makedev(11, 1), ...}) = 0
open("/dev/sr1", O_RDONLY|O_NONBLOCK|O_LARGEFILE) = 3
ioctl(3, BLKGETSIZE, 0xbf8c191c)        = 0
close(3)                                = 0
write(2, "       In some cases useful info"..., 85       In some cases useful
info is found in syslog - try
       dmesg | tail  or so
) = 85
write(2, "\n", 1
)                       = 1
exit_group(32)                          = ?

The output of dmesg as it suggested.

ISO 9660 Extensions: Microsoft Joliet Level 3
sr 1:0:1:0: [sr1] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:1:0: [sr1] Sense Key : Hardware Error [current] 
sr 1:0:1:0: [sr1] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr1, sector 112
ISOFS: unable to read i-node block
isofs_fill_super: get root inode failed
ISO 9660 Extensions: Microsoft Joliet Level 3
sr 1:0:1:0: [sr1] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:1:0: [sr1] Sense Key : Hardware Error [current] 
sr 1:0:1:0: [sr1] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
end_request: I/O error, dev sr1, sector 112
ISOFS: unable to read i-node block
isofs_fill_super: get root inode failed
sr 1:0:1:0: [sr1] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 1:0:1:0: [sr1] Sense Key : Hardware Error [current] 
sr 1:0:1:0: [sr1] Add. Sense: Timeout on logical unit
end_request: I/O error, dev sr1, sector 64
isofs_fill_super: bread failed, dev=sr1, iso_blknum=16, block=16

Comment 4 stanl 2008-06-16 17:50:41 EDT
It isn't mount itself causing the problem.  I ran the version from F7 on the F9
box, and got the identical error.  The error number was different, but the error
was the same.  So it is something in the kernel interaction with the IDE device
that is causing the problem.  I'm not sure what that would be.  Is the the scsi
driver/emulator?  HAL?  udev?
Comment 5 Chuck Ebbert 2008-06-16 22:53:39 EDT
(In reply to comment #3)
> sr 1:0:1:0: [sr1] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)

Most likely your cables are bad, the drives are on the wrong connectors or the
drives are not jumpered correctly.
Comment 6 stanl 2008-06-16 23:49:27 EDT
Thank you for taking the time to respond.  I would agree with you *except* it
all works just fine in Fedora 7 on the same machine.  I just reboot, start
Fedora 7 and the same DVD that gives the errors in Fedora 9 is recognized and
placed on the desktop.  Several times in both with consistent behavior.  I'll
reseat the cables, but these drives have been working for years in this
configuration.  Since Fedora 4.  I don't know enough about the chain of events
internally to pick the next likely place to look, but I will keep chugging away
at it.  
Comment 7 Henry Lajoie 2008-07-05 22:56:53 EDT
A similar issue occurs with USB disks.  I've had some success getting it to work
by modifying the configuration of dbus (/etc/dbus-1/system.conf) to set
"max_connections_per_user" to 256.  I don't know why but this has fixed things
with limited success (1 out of 2 computers currently).  There are other problems
that are solved by setting this as well.
Comment 8 Henry Lajoie 2008-07-05 23:04:16 EDT
(In reply to comment #7)
sorry I forgot to add, mounting the drive manually as root works
Comment 9 Philippe A 2008-07-12 10:13:01 EDT
I am experiencing the same problem with discs burned with K3B. After the burn is
complete and reported to be successful, inserting the disc in the drive results
in the following messages:

sr 2:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
sr 2:0:0:0: [sr0] Sense Key : Hardware Error [current]
sr 2:0:0:0: [sr0] Add. Sense: Timeout on logical unit
end_request: I/O error, dev sr0, sector 76912
Buffer I/O error on device sr0, logical block 9614

The drive's light flashes quite a bit before it settles and I can access the
disc contents.

This issue does not happen with discs burned under Fedora 8 or earlier versions.
They  mount just fine.

Another issue that may be related or not: when I eject, I have to remove the
disc quickly because the drive closes itself almost immediately. When the drive
is empty and I eject, it stays open. Weird!
Comment 10 Ingo Wald 2008-07-17 00:05:17 EDT
I get exactly the same error messages, but only when ripping with K3B. The DVD
itself does get properly recognized, and the right icon with the right title
appears on the desktop; but as soon as I start ripping, I get these errors in
the kernel log (and needless to say, ripping the DVD gets stuck). In my case, it
happens with Fedora 8, 2.6.25.9-40.fc8, on a Thinkpad T60. I previously ripped
DVDs on exactly that machine (using an older F8 version), so it's not the
hardware that has the problems.
Comment 11 Ventsislav Genchev 2008-07-28 14:43:46 EDT
I can also confirm the bug with DVD burned with CdXBurner.

Here is the dmesg output:

grow_buffers: requested out-of-range block 18446744073709431952 for device sr0
UDF-fs: No partition found (1)

To resolve the issue I had to manually mount the DVD with:

mount -t iso9660 /dev/cdrom cdrecorder/

I suppose something is wrong with the file system detection.
Comment 12 jjwei 2008-08-17 12:43:16 EDT
Have same problem on toshiba laptop dvd-rom sd-c2402 when mounting dvd(the drive just keep cranking forever), and mount cd is more likely to success.  Fedora core 1(on the same machine) mount both dvd and cd without problem, and same dvd have no problem on desktop dvdrom(boot or mount).

seems it is related to the new kernel(file system) on old dvdrom drive, 

 and same problem when try to use dvd to install Fedora 9 on laptop(drive keep cranking after select text installation, have to use cd and netinstall)
Comment 13 Bug Zapper 2009-06-09 21:31:24 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Bug Zapper 2009-07-14 11:50:08 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.