Bug 450738 - Authentication failed when editting a group
Authentication failed when editting a group
Status: CLOSED WONTFIX
Product: 389
Classification: Community
Component: UI - Gateway/Phonebook (Show other bugs)
1.3.0
All Linux
low Severity low
: ---
: ---
Assigned To: Rich Megginson
Ben Levenson
:
Depends On:
Blocks: 389_1.3.0
  Show dependency treegraph
 
Reported: 2008-06-10 14:58 EDT by Anh Nguyen
Modified: 2015-11-13 15:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 15:07:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anh Nguyen 2008-06-10 14:58:55 EDT
Description of problem:
DS failed to search for the group entry that is being editted.

Version-Release number of selected component (if applicable):


How reproducible:

very
Steps to Reproduce:
1. find <groups> where the <name> is <*>
2. click on a group, e.g., <Accounting Managers>
3. click <edit group>
4. click <continue>
  
Actual results:

A message saying : " Searched and found 0 entries where the name sounds like or
contains 'Acounting Managers'
Expected results:
an edit page for this group

Additional info:
[10/Jun/2008:09:42:44 -0700] conn=325 op=2 SRCH base="dc=example, dc=com" scope=
2 filter="(&(objectClass=person)(|(cn=*Accounting Managers*)(sn=*Accounting Mana
gers*)(cn~=Accounting Managers)(sn~=Accounting Managers)))" attrs="objectClass t
itle"
[10/Jun/2008:09:42:44 -0700] conn=325 op=2 RESULT err=0 tag=101 nentries=0 etime
=0
Comment 1 Rich Megginson 2008-06-11 17:30:45 EDT
To clarify - if you are not authenticated, and you press Edit Group as in step
3, you get the "Authenticate (log in) to the directory" window, with "Accounting
Managers" pre-filled in in the "Please type your name:" field.  The failure is
because you cannot authenticate as "Accounting Managers" because that is a
group, and you must authenticate as a user.  At this point, I suppose the
correct thing to do would be to let the user select the user to use to
authenticate, or auth as directory manager.

I've confirmed that this is how RHDS 7.1 works, so at least this is not a
regression.  So I'm leaving this on the bug list, as low priority.
Comment 3 Martin Kosek 2012-01-04 08:44:49 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/121

Note You need to log in before you can comment on or make changes to this bug.