Bug 450752 - firefox crashed
firefox crashed
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 16:13 EDT by David
Modified: 2008-10-24 08:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 08:39:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core dump from firefox? (6.90 MB, application/x-gzip)
2008-06-10 16:13 EDT, David
no flags Details
crash backtrace (12.62 KB, text/plain)
2008-06-12 18:03 EDT, David
no flags Details
another crash backtrace (11.96 KB, text/plain)
2008-06-12 18:49 EDT, David
no flags Details

  None (edit)
Description David 2008-06-10 16:13:21 EDT
Description of problem:
firefox crashed.

Version-Release number of selected component (if applicable):


How reproducible:
It's only happened once so far.
Comment 1 David 2008-06-10 16:13:23 EDT
Created attachment 308863 [details]
core dump from firefox?
Comment 2 Matěj Cepl 2008-06-10 18:10:17 EDT
Output of the command

rpm -qa \*xulrunner\* \*firefox\*

please
Comment 3 David 2008-06-10 18:24:23 EDT
xulrunner-1.9-0.60.beta5.fc9.i386
firefox-3.0-0.60.beta5.fc9.i386
xulrunner-devel-1.9-0.60.beta5.fc9.i386
Comment 4 Matěj Cepl 2008-06-11 17:53:37 EDT
Sorry, I tried to be helpful and not ask you to do more work, but I am not able
to dissect your core file, so I have to ask you for your help.

Please install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of
gdb debugger. Then use command run and do whatever you did to make firefox
crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text
editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 David 2008-06-12 12:05:48 EDT
I installed firefox debuginfo and ran firefox with -g as requested.
But I get the following warning... is this expected?

Missing separate debuginfo for /usr/lib/firefox-3.0b5/firefox
Try: yum --enablerepo='*-debuginfo' install
/usr/lib/debug/.build-id/0c/4436a3cfdaa75b303e620fbef9191433de4acb.debug

As far as reproducing the problem, I've tried the same steps without
a crash.  Why can't gdb be run on the original core file now that
debuginfo is available?
Comment 6 David 2008-06-12 18:03:16 EDT
Created attachment 309146 [details]
crash backtrace
Comment 7 David 2008-06-12 18:49:13 EDT
Created attachment 309149 [details]
another crash backtrace
Comment 8 Matěj Cepl 2008-06-13 12:25:06 EDT
(In reply to comment #5)
> Why can't gdb be run on the original core file now that
> debuginfo is available?

a) It is horribly complicated -- I have discussed it with gdb maintainer here,
and it is something which is very complicated and not scriptable.

b) There are still some debuginfos missing. Please, follow the advice in the top
of the backtrace and run (as root):

debuginfo-install acl.i386 alsa-lib.i386 attr.i386 audiofile.i386 avahi.i386
bug-buddy.i386 bzip2.i386 dbus-glib.i386 elfutils.i386 esound.i386 expat.i386
fontconfig.i386 freetype.i386 gail.i386 gamin.i386 gtk-nodoka-engine.i386
gtk2.i386 gvfs.i386 hunspell.i386 keyutils.i386 lcms.i386 libXScrnSaver.i386
libXau.i386 libXcomposite.i386 libXcursor.i386 libXdmcp.i386 libXext.i386
libXfixes.i386 libXft.i386 libXi.i386 libXinerama.i386 libXrandr.i386
libXrender.i386 libXt.i386 libbeagle.i386 libcap.i386 libcroco.i386
libflashsupport.i386 libgsf.i386 libjpeg.i386 libpng.i386 librsvg2.i386
libselinux.i386 libxcb.i386 nspr.i386 nss.i386 pixman.i386 pulseaudio.i386
sqlite.i386

c) however, the backtraces are at least readable enough to see that both crashes
are in different places -- one is in flashplayer (which wouldn't be our
problem), but the other one is somewhere in firefox.
Comment 9 Martin Stransky 2008-10-24 08:39:08 EDT
The first crash comes from flash-plugin, it's not a part of firefox but closed-source browser plugin. Please reopen if you find a reliable way how we can reproduce this issue.

Note You need to log in before you can comment on or make changes to this bug.