Bug 450756 - Strange logic in postinstall script
Strange logic in postinstall script
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 16:36 EDT by Göran Uddeborg
Modified: 2008-09-17 14:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 14:34:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2008-06-10 16:36:45 EDT
Description of problem:
The postinstall script contains this code:

[ -f /usr/share/selinux/devel/include/build.conf ] && /usr/bin/sepolgen-ifgen  >
/dev/null 
/usr/bin/sepolgen-ifgen  > /dev/null

Surely, that must be broken?  First the presence of a file from
selinux-policy-devel is checked.  If it is there, sepolgen-ifgen is run.  Then
on the next line, sepolgen-ifgen is run all the same!  (Again, if the build.conf
file was there.)

The meaning of the program seems to be to generate a file
/var/lib/sepolgen/interface_info.  On my systems, which does not have
selinux-policy-devel installed, it is empty.  I haven't yet figured out if it is
a problem to have an empty such file, but I thought I'd bug report the
apparently confused script anyway.

Version-Release number of selected component (if applicable):
policycoreutils-2.0.47-2.fc9
Comment 1 Daniel Walsh 2008-06-16 06:22:37 EDT
Fixed in policycoreutils-2.0.49-7.fc9

Note You need to log in before you can comment on or make changes to this bug.