Bug 450784 - RFE: Enhance Thunar's 'Send to' menu
RFE: Enhance Thunar's 'Send to' menu
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Thunar (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 19:51 EDT by Christoph Wickert
Modified: 2008-10-28 06:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.9.3-1.fc10
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 06:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of my Thunar 'Send to' menu (7.01 KB, image/png)
2008-06-10 19:51 EDT, Christoph Wickert
no flags Details
Send to "Bluetooth OBEX Recipient" using sendto-bluetooth (345 bytes, text/plain)
2008-06-10 19:55 EDT, Christoph Wickert
no flags Details
Send to "Audacious Playlist" (496 bytes, text/plain)
2008-06-10 19:59 EDT, Christoph Wickert
no flags Details
Send to "Bluetooth OBEX Recipient" using gnome-obex-send (386 bytes, text/plain)
2008-06-10 20:00 EDT, Christoph Wickert
no flags Details
Send to "Printer" using xfprint (274 bytes, text/plain)
2008-06-10 20:02 EDT, Christoph Wickert
no flags Details

  None (edit)
Description Christoph Wickert 2008-06-10 19:51:30 EDT
Description of problem:
Currently the Send to menu is a little sparse. We should add more desktop files
to /usr/share/Thunar/sendto. We can add whatever we want, if the corresponding
application is not installed the entry simply will not show up in the menu, so
we don't need to introduce additional dependencies. I'm going to attach some two
desktop files, more ideas are welcome.

Version-Release number of selected component (if applicable):
Thunar-0.9.0-4.fc9

Additional info:
thunar-sendto-email.desktop lacks an icon because the referenced name is not
available on Fedora. I suggest to use "mail-message-new" instead, this will
result in the icon shown in the screenshot I'm attaching.
Comment 1 Christoph Wickert 2008-06-10 19:51:30 EDT
Created attachment 308872 [details]
Screenshot of my Thunar 'Send to' menu
Comment 2 Christoph Wickert 2008-06-10 19:55:49 EDT
Created attachment 308873 [details]
Send to "Bluetooth OBEX Recipient" using sendto-bluetooth
Comment 3 Christoph Wickert 2008-06-10 19:59:13 EDT
Created attachment 308875 [details]
Send to "Audacious Playlist"

Note that this only is available for the filetypes that are listed in the
"MimeType" field.
Comment 4 Christoph Wickert 2008-06-10 20:00:25 EDT
Created attachment 308876 [details]
Send to "Bluetooth OBEX Recipient" using gnome-obex-send

This one is for Fedora <= 8
Comment 5 Christoph Wickert 2008-06-10 20:02:09 EDT
Created attachment 308877 [details]
Send to "Printer" using xfprint

Not sure if we should ship this because we don't want to encourage users to use
xfprint.
Comment 6 Patrice Dumas 2008-06-11 13:43:46 EDT
I don't object with adding those, but they should be added by the 
application that are launched. And it seems wrong to do this for 
thunar/xfce only, it should certainly be shared by freedesktop 
compliant desktops.
Comment 7 Christoph Wickert 2008-06-11 14:31:32 EDT
Patrice, I can't follow you: /usr/share/Thunar/sendto is specific to Thunar,
Nautilus doesn't have a counterpart and I doubt that Dolphin has.

If we add these desktop files to their applications we would need to make them
depend on Thunar, otherwise we will have (potentially) unowned directories.
Comment 8 Patrice Dumas 2008-06-12 05:05:08 EDT
(In reply to comment #7)
> Patrice, I can't follow you: /usr/share/Thunar/sendto is specific to Thunar,
> Nautilus doesn't have a counterpart and I doubt that Dolphin has.

Indeed, I am not saying that it exists in other desktops, but that it 
doesn't really makes sense to do it only in one desktop. This is 
something that should be submitted to freedesktop such that something 
common emerges.

> If we add these desktop files to their applications we would need to make them
> depend on Thunar, otherwise we will have (potentially) unowned directories.

There are more than one way to solve that issue (very similar with
the plugins issue), they can either be in a subpackage that depends on 
thunar, os own /usr/share/Thunar and /usr/share/Thunar/sendto too,
or have those 2 directories be in a filesystem-like package.

The other possibility would be to have thunar itself depend on the
application referred to in the sendto .desktop files. But in any case 
it seems wrong to me to add this in thunar without making sure that
the corresponding application is installed.
Comment 9 Christoph Wickert 2008-06-12 05:31:52 EDT
(In reply to comment #8)

> Indeed, I am not saying that it exists in other desktops, but that it 
> doesn't really makes sense to do it only in one desktop. This is 
> something that should be submitted to freedesktop such that something 
> common emerges.

I agree that this feature is interesting for other desktops/file managers as
well, but as long as it's not for me it's perfectly fine to support/enhance it
in those file mangers where it's available.

> There are more than one way to solve that issue (very similar with
> the plugins issue), they can either be in a subpackage that depends on 
> thunar, os own /usr/share/Thunar and /usr/share/Thunar/sendto too,
> or have those 2 directories be in a filesystem-like package.
> 
> The other possibility would be to have thunar itself depend on the
> application referred to in the sendto .desktop files. But in any case 
> it seems wrong to me to add this in thunar without making sure that
> the corresponding application is installed.

As mentioned before Thunar will take care of this. If the command is not found
in $PATH thunar will not display the menu entry, so I don's see a problem here.
Comment 10 Christoph Wickert 2008-06-12 05:42:17 EDT
(In reply to comment #8)

> The other possibility would be to have thunar itself depend on the
> application referred to in the sendto .desktop files.

To me this is a _really_ bad idea, because this would mean making Thunar depend
in audacious, xfprint and so on. Subpackages might be a working approach, but
IMO this is just to much overhead for a single 1 or 2 KB file. If an application
has the ability to detect things at runtime IMHO we don't need to introduce
superfluous deps.
Comment 11 Patrice Dumas 2008-06-12 07:38:45 EDT
(In reply to comment #9)

> I agree that this feature is interesting for other desktops/file managers as
> well, but as long as it's not for me it's perfectly fine to support/enhance it
> in those file mangers where it's available.

Indeed, I agree that this should stop us from doing something for thunar.

(In reply to comment #10)

>  Subpackages might be a working approach, but
> IMO this is just to much overhead for a single 1 or 2 KB file. If 
> an application has the ability to detect things at runtime IMHO we 
> don't need to introduce superfluous deps.

To it would be more logical to have those files installed by the
packages themselves even if there is auto-detection. There
is no need of subpackage if the packages installing the .desktop file
also own the directories, or there is a -filesystem package.
Comment 12 Patrice Dumas 2008-06-12 07:39:55 EDT
(In reply to comment #11)
> (In reply to comment #9)
> 
> > I agree that this feature is interesting for other desktops/file managers as
> > well, but as long as it's not for me it's perfectly fine to support/enhance it
> > in those file mangers where it's available.
> 
> Indeed, I agree that this should stop us from doing something for thunar.

Should have been 'I agree that this should not stop us from doing something 
for thunar'.

It would be nice if upstream tried to do something in freedesktop, though.
Comment 13 Christoph Wickert 2008-06-19 19:32:10 EDT
(In reply to comment #11)
> To it would be more logical to have those files installed by the
> packages themselves even if there is auto-detection.

I agree it would be more logical but IMHO it is more important that we - the
Xfce maintainers - remain in control of what is installed in
/usr/share/Thunar/sendto. Think about updates, for example if Thunar switches to
another approach in Xfce 4.6 or if fdo specs change. Do you really want to push
updates for audacious, bluez-gnome and so on then?
Comment 14 Patrice Dumas 2008-06-20 03:23:26 EDT
(In reply to comment #13)
> (In reply to comment #11)
> > To it would be more logical to have those files installed by the
> > packages themselves even if there is auto-detection.
> 
> I agree it would be more logical but IMHO it is more important that we - the
> Xfce maintainers - remain in control of what is installed in
> /usr/share/Thunar/sendto. Think about updates, for example if Thunar switches to
> another approach in Xfce 4.6 or if fdo specs change. Do you really want to push
> updates for audacious, bluez-gnome and so on then?

If fdo specs change, yes. But if solely xfce changes, no.

Indeed centralized management of the sendto menu is possible, still 
I think decentralizing it would be better. There are examples of both
type, selinux is still very centralized, while pam configuration or
the hicolor theme are decentralized.

In the end, doing how you prefer is best since there is no obvious 
better way.
Comment 15 Christoph Wickert 2008-10-28 06:09:17 EDT
Added thunar-sendto-bluetooth.desktop and thunar-sendto-audacious-desktop to thunar-0.9.3 in rawhide. Closing.

Note You need to log in before you can comment on or make changes to this bug.