Bug 450811 - "File not found by glob" when installing from http:// with special characters
Summary: "File not found by glob" when installing from http:// with special characters
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 488704
TreeView+ depends on / blocked
 
Reported: 2008-06-11 07:22 UTC by Jan Hutař
Modified: 2009-03-05 10:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 488704 (view as bug list)
Environment:
Last Closed: 2009-03-04 12:31:24 UTC


Attachments (Terms of Use)

Description Jan Hutař 2008-06-11 07:22:26 UTC
Description of problem:
When I try to install package from http:// when there is a "~" in the URL, I 
get "File not found by glob" error message. Installing from "normal" URLs works 
fine.


Version-Release number of selected component (if applicable):
rpm-4.4.2.3-2.fc9.x86_64


How reproducible:
always


Steps to Reproduce:
1. # rpm -ivh 'http://server/~user/repo/package-3.1.0.320-1.i386.rpm'


Actual results:
error: File not found by glob: http://server/~user/repo/
package-3.1.0.320-1.i386.rpm


Expected results:
package is installed


Additional info:
Package itself is ok and installable:
# wget 'http://server/~user/repo/package-3.1.0.320-1.i386.rpm'
...
2008-06-11 09:04:08 (108 MB/s) - `package-3.1.0.320-1.i386.rpm' saved
# rpm -ivh package-3.1.0.320-1.i386.rpm 
Preparing...                ########################################### [100%]
   1:package                ########################################### [100%]

Comment 1 lexual 2009-03-03 23:57:55 UTC
Can the reporter please give a real url for me to test this with?

Comment 2 Jan Hutař 2009-03-04 12:21:59 UTC
Hello,
you can test on:

rpm -ivh 'http://people.redhat.com/~varekova/gzip-1.3.3-16.rhel4.test.i386.rpm'

I was not able to reproduce on the F10, but was on RHEL-5.3.


Note You need to log in before you can comment on or make changes to this bug.