Bug 450820 - rpms installed despite depending on an rpm which failed to install correct with cpio: read errors.
rpms installed despite depending on an rpm which failed to install correct wi...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-11 04:20 EDT by Donald Cohen
Modified: 2009-06-19 10:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 09:42:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald Cohen 2008-06-11 04:20:42 EDT
Description of problem:
None of the openoffice products start on newly installed and updated FC9.
When you click on applications - office - xxx you see in the taskbar 
that it's starting and then it just disappears without a window appearing.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Install fc9
2. click as above
3. see what happens
  
Actual results:
see above

Expected results:
a window should appear for writer or whatever

Additional info:
When I found the program that was being called by the office menu (which was not
easy - could that be fixed?) I found that the complaint was libxo680li.so was
not found.  I found that this is supplied by package openoffice.org-core, so I
did yum install of that and then things started to work.
It seems hard to believe that this could have not been caught before.
But I don't know anything special about my installation - just followed all the
defaults from net install.
Comment 1 Caolan McNamara 2008-06-11 04:30:26 EDT
It should be impossible to install an OpenOffice component without the
dependencies pulling in the correct -core rpm 

i.e.
rpm -q --requires openoffice.org-writer|grep core
openoffice.org-core = 1:2.4.1-17.3.fc9

So the writer rpm *does* require openoffice.org-core. So whatever the problem is
I strongly suspect it is not a problem in the openoffice.org rpms, and all my
own fresh installs of F-9 or upgrades from F-8 went fine.

Were you upgrading or installing from scratch ? There should have been an
install.log left in /root by anaconda. Is there anything in there that looks
suspicious.
Comment 2 Donald Cohen 2008-06-11 04:53:59 EDT
This was installed from scratch starting from a net install cd.  The download
was two or three days ago, then the update was less than one day ago.
I think there was a problem in the install where it said I could either retry or
give up on the install (after the install had been going on for hours) - I did a
retry and was relieved that it seemed happy.

Aha! here's the relevant excerpt from install.log:
 ...
 Installing bsh-1.3.0-12jpp.3.fc9.i386 
 Installing openoffice.org-core-2.4.0-12.8.fc9.i386 
 error: unpacking of archive failed on file   
/usr/lib/openoffice.org/program/libxo680li.so;484dbcbc: cpio: read 
 Installing openoffice.org-graphicfilter-2.4.0-12.8.fc9.i386 
 Installing xorg-x11-drv-neomagic-1.2.0-1.fc9.i386  
 ... also ...
 Installing gnome-python2-bonobo-2.22.0-2.fc9.i386 
 Installing openoffice.org-writer2latex-0.5-2.fc9.i386 
 /usr/bin/unopkg: line 16: /usr/lib64/openoffice.org/program/unopkg: No such 
file or directory 
 /usr/bin/unopkg: line 16: exec: /usr/lib64/openoffice.org/program/unopkg:   
cannot execute: No such file or directory 
 Installing openoffice.org-writer-2.4.0-12.8.fc9.i386 

I also see a few other "no such file or directory" lines but can't tell which
name they refer to.
Comment 3 Caolan McNamara 2008-06-11 05:07:44 EDT
There you go...

 error: unpacking of archive failed on file   
/usr/lib/openoffice.org/program/libxo680li.so;484dbcbc: cpio: read 

So unpacking the original openoffice-org-core rpm failed. That's why libxo was
missing, the rpm was corrupt and it wasn't extracted correctly. So no bug per-se
in OOo itself.

But surely if a rpm failed to install it shouldn't be possible to continue past
that and install rpms that depend on it. That seems odd, but maybe there's a
good reason for that. Not sure if the installer or rpm itself is the more likely
actor here.
Comment 4 Chris Lumens 2008-07-24 09:42:49 EDT
It's lame, but there's not really much we can do here.  If we catch and display
the error, you're not going to be able to do anything other than quit, which
will leave you with a half-installed/half-broken system.  If we keep going,
you'll end up with a potentially broken subset of packages, but hopefully the
system as a whole will be usable to the point where you can repair whatever went
wrong.
Comment 5 Charlie Brady 2009-06-19 10:44:52 EDT
Yes, that's lame. Leaving the system half-installed and telling you that you need to find a good install source is infinitely better than pretending that the install completed, and having a partially installed system which won't work correctly.

Note You need to log in before you can comment on or make changes to this bug.