Bug 450826 - yum fails to uninstall kernel-xen
yum fails to uninstall kernel-xen
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-11 04:54 EDT by Guido Ledermann
Modified: 2014-01-21 18:03 EST (History)
6 users (show)

See Also:
Fixed In Version: yum-3.2.17-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 11:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guido Ledermann 2008-06-11 04:54:33 EDT
Description of problem:
When I try to uninstall kernel-xen I get an error (in German here)
FEHLER mit rpm_check_debug gegen depsolve:
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 193, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 377, in doTransaction
    print msg
  File "/usr/lib64/python2.5/codecs.py", line 303, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 22: ordinal
not in range(128)


Version-Release number of selected component (if applicable):
yum.noarch.3.2.16-2.fc9

How reproducible:
Anytime

Steps to Reproduce:
1. yum remove kernel-xen
  
Actual results:
Error message

Expected results:
Selected packages should be uninstalled.
Comment 1 James Antill 2008-06-11 12:39:29 EDT
 This is very suspicious as python shouldn't be generating these messages ...
but can you try this patch (added upstream, the file is /usr/share/yum-cli/cli.py):

diff --git a/cli.py b/cli.py
index ff24ac6..cb16e76 100644
--- a/cli.py
+++ b/cli.py
@@ -45,7 +45,7 @@ from yum.rpmtrans import RPMTransaction
 import signal
 import yumcommands
 
-from yum.misc import to_unicode
+from yum.misc import to_unicode, to_utf8
 
 def sigquit(signum, frame):
     """ SIGQUIT handler for the yum cli. """
@@ -374,7 +374,7 @@ class YumBaseCli(yum.YumBase, output.YumOutput):
             if msgs:
                 print _('ERROR with rpm_check_debug vs depsolve:')
                 for msg in msgs:
-                    print msg
+                    print to_utf8(msg)
     
                 return 1, [_('Please report this error in bugzilla')]
 
Comment 2 Guido Ledermann 2008-06-12 02:31:07 EDT
I applied the patch manually because I get a "malformed" error. The error
message still comes up.
Comment 3 Jeremy Katz 2008-06-12 15:15:42 EDT
What locale are you running in?
Comment 4 Guido Ledermann 2008-06-12 15:32:18 EDT
/etc/sysconfig/i18n says 
LANG="de_DE.utf8"

Comment 5 Guido Ledermann 2008-06-23 01:42:21 EDT
I don't know what's changed in the meanwhile, but I could successfully remove
the kernel now.
Comment 6 Fedora Update System 2008-07-09 10:51:21 EDT
yum-3.2.17-1.fc9 has been submitted as an update for Fedora 9
Comment 7 Fedora Update System 2008-07-09 17:50:56 EDT
yum-3.2.17-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6301
Comment 8 Jan Hutař 2008-07-22 08:48:51 EDT
I was able to siccesfully install and remove kernel-xen with new 
yum-3.2.17-1.fc9:

# LANG="de_DE.utf8" yum remove kernel-xen

According the comment #5 you do not have this problem now right?
Comment 9 Guido Ledermann 2008-07-22 10:46:14 EDT
(In reply to comment #8)
> According the comment #5 you do not have this problem now right?

I have no more problems with yum-3.2.17-1.fc9. I did a 
yum install kernel-xen
and
yum remove kernel-xen
without any problem.
Comment 10 Fedora Update System 2008-07-22 13:28:23 EDT
yum-3.2.17-2.fc8 has been submitted as an update for Fedora 8
Comment 11 Fedora Update System 2008-07-23 22:10:55 EDT
yum-3.2.17-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-08-07 13:17:10 EDT
yum-3.2.18-1.fc8 has been submitted as an update for Fedora 8
Comment 13 Fedora Update System 2008-08-27 14:02:46 EDT
yum-3.2.19-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/yum-3.2.19-1.fc8
Comment 14 Fedora Update System 2008-09-10 02:58:40 EDT
yum-3.2.19-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.