Bug 45085 - --check busted init.d/functions
--check busted init.d/functions
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-19 22:49 EDT by Bryce Nesbitt
Modified: 2014-03-16 22:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-19 22:49:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryce Nesbitt 2001-06-19 22:49:03 EDT
The daemon() function offers a --check option, which has broken
parsing on one of it's two forms:

            --check=?*)
!                  base=${1#--check=}
!                  gotbase="yes"
                   shift
                   ;;
--- 93,97 ----
                   ;;
            --check=?*)
!                  base=${1#--user=}
                   shift
                   ;;

it also seems to not work, but fixing the parsing is the first step.
Comment 1 Bill Nottingham 2001-07-09 01:44:38 EDT
it doesn't work due to a rather dumb bug, that will be fixed in 6.00-1.

Note You need to log in before you can comment on or make changes to this bug.