Bug 4510 - lpd dies when host or user cannot be authenticated
lpd dies when host or user cannot be authenticated
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: lpr (Show other bugs)
6.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-13 10:38 EDT by sas
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-28 01:43:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sas 1999-08-13 10:38:36 EDT
I have tried linux 5.2 and 6 for this. When lpd receives
either a print
request from an unknown user or an unknown host it just
dies. Some files
must be removed from /var/spool/lpd/hp0 and the demon
restarted. As a
consequence of whatever it is that happened there are a few
zero-length cf
files left, and the first printer job displayed by lpq is
zero length.

-rw-rw----   1 root     root            0 Jul 23 15:44
cfA033iQtINkn
-rw-rw----   1 root     root            0 Jul 23 15:44
cfA033iWoNc3o
-rw-rw----   1 root     root            0 Jul 23 15:44
cfA033ib246jA
-rw-rw----   1 root     root           87 Jul 23 15:44
cfA033iltzOgg

I would prefer that lpd just reject the job!
Comment 1 zurk 1999-08-15 20:07:59 EDT
i believe the lpr 0.39 rpm solves this altho i could be wrong. I think
something similar was posted earlier..although no rpm was put on the
errata section.
Comment 2 Preston Brown 1999-08-28 01:43:59 EDT
this has been solved for the next release (6.1).

Note You need to log in before you can comment on or make changes to this bug.