Bug 451047 - yum update sorts files by size for downloading
yum update sorts files by size for downloading
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
https://mail.google.com/mail/?shva=1#...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-12 11:30 EDT by Don Russell
Modified: 2014-01-21 18:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 11:44:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Russell 2008-06-12 11:30:26 EDT
Description of problem:
More of an "enhancement"...
"yum update" appears to sort files for download by size, smallest first.
Not sure if this is a deliberate sort, or just coinicdence. But sorting so the
largest is download first conveys more user information and improves *perceived
progress*.


Version-Release number of selected component (if applicable):
yum-3.2.16-2.fc9.noarch

How reproducible:
Always


Steps to Reproduce:
1. yum update
2. reply y to prompt asking if it's OK to download xxx MB
3.
  
Actual results:
files are downloaded, smallest first

Expected results:
Actually I *expected* no particular order.
But, since the order appears to be deliberately smallest first, I'd like to
suggest it be largest first:
- While waiting/watching a user would always know the next file is the same size
or SMALLER than the one just downloaded
- The *Perception* would be that the process is speeding up instead of slowing
down :-)

Additional info:
See initial thread on fedora forum:
https://mail.google.com/mail/?shva=1#label/Fedora%2FGeneral/11a797f660cba3a0
Comment 1 James Antill 2008-06-12 11:44:50 EDT
 My understanding from people who have taken psychology is that people split
into "first impression lasts" and "later impression eventually wins" ... and
that the former is _much_ more common. So it's much more likely that the
perception of largest first would be that it's slower.

 Also the point of downloading smallest first, from a purely technical point of
view, is that at any time you can break out of the download and you'll have the
largest set of _complete_ packages that you can install.
Comment 2 Don Russell 2008-06-12 23:37:19 EDT
Point 1: So provide an option to control the sort option, default to "most people".

Point 2: Not much of an argument. If a package has dependencies, what's in place
to make sure the dependency is downloaded before beginning the next package?

Also, since downloading/installing a whole set of updates was checked for
dependency issues, you can't reliably just "break out" any time and install what
you have.

Sorting files by size does not guarantee that any package is complete. What if a
common dependency IS the largest file? Worst case: The smallest file has a
dependency on the largest file. So you can't install that package until the last
file is obtained. So much for "break out any time".

Actually, the idea of simply sorting by size is a waste of resources... it
really doesn't provide any useful benefit. It looks neat and tidy, but other
than that...

If you really want to support a "break out any time" theory better, take
dependencies into account so files and their dependencies are downloaded
together, then the next set, and so on.


Note You need to log in before you can comment on or make changes to this bug.