Bug 451074 - FEAT: when the info test fails because the rpm validation of hts fails hts should snag a copy of the modified file
FEAT: when the info test fails because the rpm validation of hts fails hts sh...
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
All Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
http://hardware.redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-12 13:13 EDT by Rob Landry
Modified: 2009-01-27 17:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 17:58:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against R18 (894 bytes, patch)
2008-06-27 11:56 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Rob Landry 2008-06-12 13:13:18 EDT
Description of problem:

When the info test fails because the test was modified we may be able to learn
more by grabbing a copy of the file and trying to understand the why part; what
change the vendor is looking for in hts; most are going to be malice but some
felt shortcoming (which we may or may not agree with) in either case we'll
likely understand more of the expectations vendors have of the test suite from
this additional data point.
Comment 2 Greg Nichols 2008-06-27 11:56:18 EDT
Created attachment 310450 [details]
patch against R18
Comment 3 Greg Nichols 2008-06-27 11:56:57 EDT
Fix in HTS 5.2 R19
Comment 4 Greg Nichols 2008-08-27 21:45:45 EDT
Fix delayed to HTS 5.3
Comment 10 Yan Tian 2009-01-19 00:03:16 EST
Verified show "Saving modified source files:..." info in hts-5.3-12.
Comment 11 Yan Tian 2009-01-19 00:38:43 EST
(In reply to comment #10)
> Verified show "Saving modified source files:..." info in hts-5.3-12.

Also the modified source file was copied to /var/log/hts/runs/{NUM}/info/.
Comment 13 errata-xmlrpc 2009-01-27 17:58:33 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0047.html

Note You need to log in before you can comment on or make changes to this bug.