Bug 45110 - ndbm.h and libndbm.so belong to different packages
Summary: ndbm.h and libndbm.so belong to different packages
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: db2 (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-20 08:18 UTC by Mikhail Zabaluev
Modified: 2013-07-02 22:55 UTC (History)
1 user (show)

Fixed In Version: db4-4.3.27-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 10:15:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikhail Zabaluev 2001-06-20 08:18:31 UTC
Description of Problem:

ndbm.h resides in /usr/include/db1 and belongs to the db1-devel package,
whereas libndbm.so is a symlink to libdb2.so and belongs to the db2-devel
package.

This induces unnecessary build dependencies (and potential problems)
for perl and other sources that include ndbm.h and link against -lndbm.

Comment 1 Jindrich Novy 2006-02-15 10:15:13 UTC
The problem no more exist since db4.


Note You need to log in before you can comment on or make changes to this bug.