Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 45113 - utmp is not cleaned up if client quits improperly
utmp is not cleaned up if client quits improperly
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: openssh (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-20 05:56 EDT by Olivier Baudron
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-16 14:22:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Baudron 2001-06-20 05:56:22 EDT
The problem is with openssh-server-2.9p1-3gss and 2.9p2.

To reproduce the bug:
* open an ssh2 session (e.g: ssh -l guest localhost)
* send SIGTERM to the xterm holding this session
* type "who" on the server and notice that the client pts/ is still there

So the ssh server improperly cleans /var/run/utmp.
The problem is that, it can completly messes up the logs on the system.
Also note, that if you quit the session with ALT-D, everything works fine.
Comment 1 Olivier Baudron 2001-08-16 14:22:24 EDT
This is fixed in openssh cvs.
Comment 2 Olivier Baudron 2001-11-14 09:56:35 EST
Now, fixed in openssh-3.0p1-1.

Note You need to log in before you can comment on or make changes to this bug.