Bug 451178 - eeePC (HDA INTEL) i-mic and e-mic are inverted
eeePC (HDA INTEL) i-mic and e-mic are inverted
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraMini/Mobility
  Show dependency treegraph
 
Reported: 2008-06-13 04:34 EDT by Carlo Raudino
Modified: 2008-10-02 00:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-14 06:42:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Untested patch (732 bytes, patch)
2008-06-13 14:21 EDT, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Carlo Raudino 2008-06-13 04:34:37 EDT
Description of problem: to get internal mic work, in eeepc (HDA Intel audio)
there's the need to "activate" the e-mic switch in alsa mixer... it looks like
they are inverted...

How reproducible:
Double leftclick the volume icon, open preferences and enable e-Mic and e-Mic
Boost. In options select input source: e-Mic 


Expected results:
i-mic activating the internal mic :-)
Comment 1 Bastien Nocera 2008-06-13 10:42:17 EDT
Which model of EeePC do you have? For the Asus EeePC 701, a quirk has been setup
in more recent versions of ALSA:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=291702f017efdfe556cb87b8530eb7d1ff08cbae;hp=f6e9852ad05fa28301c83d4e2b082620de010358

The "ASUS Eeepc EP20" is also quirked in there.

Could you show the output of lspci and "lspci -n" or your setup?
Comment 2 Carlo Raudino 2008-06-13 10:54:34 EDT
It's an eeePC 701

output of lspci -n
00:00.0 0600: 8086:2590 (rev 04)
00:02.0 0300: 8086:2592 (rev 04)
00:02.1 0380: 8086:2792 (rev 04)
00:1b.0 0403: 8086:2668 (rev 04)
00:1c.0 0604: 8086:2660 (rev 04)
00:1c.2 0604: 8086:2664 (rev 04)
00:1d.0 0c03: 8086:2658 (rev 04)
00:1d.1 0c03: 8086:2659 (rev 04)
00:1d.2 0c03: 8086:265a (rev 04)
00:1d.3 0c03: 8086:265b (rev 04)
00:1d.7 0c03: 8086:265c (rev 04)
00:1e.0 0604: 8086:2448 (rev d4)
00:1f.0 0601: 8086:2641 (rev 04)
00:1f.2 0101: 8086:2653 (rev 04)
00:1f.3 0c05: 8086:266a (rev 04)
01:00.0 0200: 168c:001c (rev 01)
Comment 3 Bastien Nocera 2008-06-13 13:07:49 EDT
And lspci? My pciids database is only on my hard disk, not in my head ;)

I don't see the sound device as would be used by the EeePC...
+       SND_PCI_QUIRK(0x1043, 0x82a1, "ASUS Eeepc", ALC662_ASUS_EEEPC_P701),

Could you please also try:
rmmod snd-hda-intel 
modprobe snd-hda-intel model=eeepc-p701

This should force the quirks to be that for the Eeepc, instead of autodetecting.
Comment 4 Carlo Raudino 2008-06-13 14:07:44 EDT
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 04)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML
Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express
Graphics Controller (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High
Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 04)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 3 (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 04)
01:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg
Wireless PCI Express Adapter (rev 01)

___________________________________________________________

for rmmod:
ERROR: Module snd_hda_intel is in use
Comment 5 Carlo Raudino 2008-06-13 14:14:59 EDT
OK, this works:
modprobe snd-hda-intel model=eeepc-p701


(without rmmod snd-hda-intel)

Internal mic, works as i-mic.

Comment 6 Bastien Nocera 2008-06-13 14:21:05 EDT
Created attachment 309268 [details]
Untested patch

That might be enough to make it work.
Comment 7 Bastien Nocera 2008-06-13 14:22:31 EDT
Jaroslav, any comments on the patch? Would somebody mind kicking a scratch build
with the patch for Carlo to test?
Comment 8 Chuck Ebbert 2008-06-14 04:25:37 EDT
ALSA uses the subvendor/subdevice for quirks, not vendor/device.

Please post output of lspci -vnn
Comment 9 Carlo Raudino 2008-06-14 06:42:35 EDT
I don't know what update did the trick (yesterday and today a lot of updates
came from repository..and I update everyday) .  2.6.25.6-55 kernel? I don't know

Now i-mic seems to work as i-mic!
Comment 10 Carlo Raudino 2008-06-14 06:46:38 EDT
uhm...is "modprobe snd-hda-intel model=eeepc-p701" permanent? Possibly is
because of this command that now imic works without tweaks at every boot. Or not? 
Comment 11 Carlo Raudino 2008-06-14 08:15:49 EDT
I attached here https://bugzilla.redhat.com/show_bug.cgi?id=451232   a dmesg log
with the last rawhide kernel...take a look at the alsa messages....
Comment 12 Bastien Nocera 2008-06-16 18:25:19 EDT
(In reply to comment #10)
> uhm...is "modprobe snd-hda-intel model=eeepc-p701" permanent? Possibly is
> because of this command that now imic works without tweaks at every boot. Or not? 

No, it's not permanent, the module is inserted with the correct quirk because
the patch I mentioned above (and not the one I posted, which would have been the
same if it was right...) wasn't in older versions.

So the newer versions can detect your card and apply the quirks as expected.
It's fixed properly :)

Note You need to log in before you can comment on or make changes to this bug.