Bug 451218 - toped crashes on startup
toped crashes on startup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: toped (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-13 09:48 EDT by Tim Wegener
Modified: 2008-07-31 18:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.9.0-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-30 16:04:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug-buddy report (4.26 KB, text/plain)
2008-06-13 09:48 EDT, Tim Wegener
no flags Details

  None (edit)
Description Tim Wegener 2008-06-13 09:48:06 EDT
Description of problem:
The toped layout editor crashes immediately, subsequently launching bug-buddy.

Version-Release number of selected component (if applicable):
toped-0.8.6-2.fc9.i386
wxGTK-2.8.7-2.fc9.i386

How reproducible:
always

Steps to Reproduce:
1. run 'toped' from the terminal
  
Actual results:
toped crashes, subsequently launching bug-buddy

Expected results:
toped layout editor window appearing

Additional info:
toped starts up properly in Fedora 8 (though with instsability issues after
using it for a while).
Comment 1 Tim Wegener 2008-06-13 09:48:06 EDT
Created attachment 309210 [details]
bug-buddy report
Comment 2 Svilen Krustev 2008-07-23 16:42:22 EDT
The problem is due to the lack of a proper GLX visual - most likely accumulation
buffers and/or double buffering.
The problem is not seen on previous Fedora versions, because (most likely) ATi
or nVidia drivers were used by the packagers.

To prevent the crash - a patch is submitted here (more than a month now -
Chitlesh ?). 
http://prdownload.berlios.de/toped/release_0.9_patch_652_678.patch

Nevertheless the program will not run normally without required GLX visual.
Comment 3 Chitlesh GOORAH 2008-07-26 08:54:40 EDT
Svilen, your patch isn't helping.

First it is doing reverse-patching.

Second:
./configure: line 24337: AX_CHECK_GL: command not found
./configure: line 24346: AX_CHECK_GLU: command not found

Third,
fails to start
Comment 4 Svilen Krustev 2008-07-26 11:43:09 EDT
Somehow a wrong patch ended up in the repository.The patch was replaced.
The new patch is:

http://prdownload.berlios.de/toped/release_0.9_patch_654_721.patch

Comment 5 Fedora Update System 2008-07-27 05:11:24 EDT
toped-0.9.0-2.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-07-27 05:12:00 EDT
toped-0.9.0-2.fc9 has been submitted as an update for Fedora 9
Comment 7 Chitlesh GOORAH 2008-07-27 05:12:54 EDT
I've explained the issue here:
http://clunixchit.blogspot.com/2008/07/fel-updates-on-toped-090-startup-crash.html
Comment 8 Fedora Update System 2008-07-30 16:04:24 EDT
toped-0.9.0-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-07-30 16:06:18 EDT
toped-0.9.0-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Tim Wegener 2008-07-31 11:36:55 EDT
It at least starts for me now. However after using it for a while, looking
around a moderately sized GDS layout the system crashed. The screen went black
and flickered repeatedly (like mode switching). I couldn't ssh in from another
machine. It did respond to ctrl-alt-del, however, and rebooted.

This is probably a problem with the Intel graphics driver, as I've had similar
problems with some other apps. 
Comment 11 Chitlesh GOORAH 2008-07-31 13:38:06 EDT
Svilen Krustev is the main developer and he is taking the bug seriously. Perhaps
soon we will have a fix.
Comment 12 Svilen Krustev 2008-07-31 18:01:29 EDT
Tim,
I do appreciate you feedback. A couple of questions:
- your configuration (is that fc9?)
- if you think that's toped specific bug - I'm not sure this is the right place
to discuss it. Please feel free to continue updating toped bug list or to post
in the mailing list.

(In reply to comment #10)
> It at least starts for me now. However after using it for a while, looking
> around a moderately sized GDS layout the system crashed. The screen went black
> and flickered repeatedly (like mode switching). I couldn't ssh in from another
> machine. It did respond to ctrl-alt-del, however, and rebooted.
> 
> This is probably a problem with the Intel graphics driver, as I've had similar
> problems with some other apps. 


Note You need to log in before you can comment on or make changes to this bug.