Bug 451229 - rootfiles package was pulled straight from RHEL
rootfiles package was pulled straight from RHEL
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rootfiles (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-13 10:41 EDT by Justin Sherrill
Modified: 2008-11-08 22:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-08 22:22:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2008-06-13 10:41:42 EDT
Description of problem:

The package rootfiles-8.1-1.1.1.noarch was pulled straight from RHEL and was not
rebuilt.  It was simply resigned.  This means that the vendor field still says
"Red Hat, Inc." .  

Not sure if this was intentional or not, but it doesn't seem proper.
Comment 1 Justin Sherrill 2008-06-13 12:00:27 EDT
Talking with Jon Stanley, he is going to rebuild all the Fedora packages with
the correct vendor that need them. Assigning to him.
Comment 2 Jon Stanley 2008-11-08 22:22:36 EST
The problem was actually solved another way in Spacewalk (which was the initial reason this was noticed). We now take into account the md5sums of packages (thereby catching patches signed with different keys). The root of the problem was that many vendors (RH, Fedora, CentOS) included files with the same NEVRA but signed with different keys, and Spacewalk/Satellite keyed off of the NEVRA for determining the uniqueness of a package.

This bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.