Bug 451321 - please rebuild - jgroups
please rebuild - jgroups
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: jgroups (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
badVendor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-13 15:51 EDT by Jon Stanley
Modified: 2008-12-11 15:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 15:49:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Stanley 2008-06-13 15:51:35 EDT
Package lists Red Hat, Inc as a vendor tag. This causes various problems. I've
verified that the tag is not set in the spec, so a rebuild should fix it. Please
bump release and rebuild for rawhide.

I'd do this myself, but package ACL's are preventing me from committing. Also
consider removing those.
Comment 1 Deepak Bhole 2008-11-05 13:22:06 EST
The vendor tag is added by the build system, it cannot be removed. What problems are you seeing due to it?
Comment 2 Jon Stanley 2008-11-09 15:52:42 EST
Right, there was a problem that I couldn't talk about publicly at the time, but I can now.  Spacewalk was using NEVRA as a differentior between two packages, figuring that no two packages should ever have identical NEVRA.  For various reasons, we were looking at using the vendor tag.

This didn't work either, specifically because of problems like this (vendor not saying Fedora Project, which it would if you built this today). We now use the md5sum of the package. This was probably built way back in the FC days, when the vendor was properly "Red Hat, Inc." and hasn't required a rebuild since.

So in short, you don't HAVE to rebuild this, but it'd be nice to get the entire distribution from one "vendor"
Comment 3 Bug Zapper 2008-11-25 21:25:16 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Deepak Bhole 2008-12-11 15:49:26 EST
This is the version of jgroups in Fedora now:

http://koji.fedoraproject.org/koji/buildinfo?buildID=61845

And it had Vendor/Packager = "Fedora Project"

Closing as fixed. Feel free to reopen if you are still having problems.

Note You need to log in before you can comment on or make changes to this bug.