Bug 451388 - unable to detect hard disk on raid controller
unable to detect hard disk on raid controller
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-p2v (Show other bugs)
unspecified
All Linux
low Severity high
: ---
: ---
Assigned To: Matthew Booth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-13 19:11 EDT by Greg Caetano
Modified: 2014-12-15 07:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-15 07:10:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-p2v log (2.42 KB, text/x-log)
2008-09-09 12:56 EDT, Greg Caetano
no flags Details
dmesg output from system to be captured (23.50 KB, application/octet-stream)
2008-09-09 12:56 EDT, Greg Caetano
no flags Details
ErrorMessage screen shot (33.84 KB, image/jpeg)
2008-09-09 12:59 EDT, Greg Caetano
no flags Details

  None (edit)
Description Greg Caetano 2008-06-13 19:11:21 EDT
Description of problem: p2v unable to detect raid disk controller based drives

Version-Release number of selected component (if applicable):0.9.7

How reproducible: always

Steps to Reproduce:
1.boot p2v live cd on any HP server with standard smart array controller
2.
3.
  
Actual results:
/tmp/virt-p2v.log reports
all_block_devices: block devices:
all_block_devices: non-removable block devices:
No non-removable block devices (hard disks, etc.) could be found on this machine.


Expected results:
Discovery of /dev/cciss/c0d0 as a block device

Additional info:
/sys/block does have cciss!c0d0 in its listing
Comment 1 Richard W.M. Jones 2008-09-09 09:02:17 EDT
There is a new version (0.9.8) on the website which includes UNTESTED
support for HP Smart Array controllers (cciss).
Comment 2 Greg Caetano 2008-09-09 12:55:02 EDT
Tested 0.9.8 on BL20p G3 and received the following error message:

Command Failed:
mount '/dev/mapper/snapcciss_c0d0' /mnt/root

RHEL3u9 system attempting to be captured - will attached screenshot, dmesg output and virt-p2v.log as requested.
Comment 3 Greg Caetano 2008-09-09 12:56:09 EDT
Created attachment 316210 [details]
virt-p2v log
Comment 4 Greg Caetano 2008-09-09 12:56:59 EDT
Created attachment 316211 [details]
dmesg output from system to be captured
Comment 5 Greg Caetano 2008-09-09 12:59:36 EDT
Created attachment 316212 [details]
ErrorMessage screen shot
Comment 7 Greg Caetano 2009-05-15 16:25:37 EDT
Tested with v0.9.9 that supports LVM snapshots and issue has been corrected. I can move systems configured for ext3 /dev/cciss/c0d0 partitions or those with LVM volumes on the /dev/cciss/c0d0.
Comment 8 Richard W.M. Jones 2011-04-13 04:50:23 EDT
virt-p2v has been rewritten.  I'm reassigning this bug
to Matt Booth to make sure that the new virt-p2v will
work with /dev/cciss devices.
Comment 9 Richard W.M. Jones 2011-08-30 06:01:26 EDT
There is a new version of virt-p2v and virt-v2v:
http://libguestfs.org/virt-v2v/
Comment 10 Richard W.M. Jones 2014-12-15 07:10:40 EST
Closing per comment 9.

Note You need to log in before you can comment on or make changes to this bug.