Bug 451389 - Suspend broken on Radeon Mobility HD 2600 Series
Suspend broken on Radeon Mobility HD 2600 Series
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-13 19:15 EDT by Martin Ebourne
Modified: 2008-11-10 19:50 EST (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-drv-ati-6.9.0-38.fc10.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-10 19:50:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Non-working suspend-resume with xorg-x11-drv-ati-6.8.0-17 (37.19 KB, text/plain)
2008-06-14 05:53 EDT, Martin Ebourne
no flags Details
Working suspend-resume with xorg-x11-drv-ati-6.8.0-16 (37.53 KB, text/plain)
2008-06-14 05:54 EDT, Martin Ebourne
no flags Details

  None (edit)
Description Martin Ebourne 2008-06-13 19:15:44 EDT
Description of problem:
Tried latest update from koji but suspend is now broken.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.8.0-17.fc9.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Suspend to RAM
2. Resume from suspend
  
Actual results:
Backlight remains off, screen black. If I try to change VT backlight comes on
but remains permanently blank.

Expected results:
Normal X display

Additional info:
xorg-x11-drv-ati-6.8.0-16.fc9.x86_64 is working fine
Comment 1 Matěj Cepl 2008-06-13 19:27:48 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Martin Ebourne 2008-06-14 05:53:14 EDT
Created attachment 309335 [details]
Non-working suspend-resume with xorg-x11-drv-ati-6.8.0-17
Comment 3 Martin Ebourne 2008-06-14 05:54:03 EDT
Created attachment 309336 [details]
Working suspend-resume with xorg-x11-drv-ati-6.8.0-16
Comment 4 Martin Ebourne 2008-06-14 05:55:17 EDT
Both log files above using automatic configuration.
Comment 5 Martin Ebourne 2008-07-17 17:06:30 EDT
Same problem still on xorg-x11-drv-ati-6.8.0-18.fc9.
Comment 6 Martin Ebourne 2008-10-05 07:45:26 EDT
Suspend still broken in the same way with xorg-x11-drv-ati-6.8.0-19.fc9.
Comment 7 Martin Ebourne 2008-10-05 15:27:24 EDT
Suspend still broken on F10 beta 2 live CD.

What can I do to help debug this? Would be really bad if F10 shipped with suspend broken when it worked with F9.
Comment 8 Martin Ebourne 2008-11-10 15:28:42 EST
This appears fixed on F10 preview release.

xorg-x11-drv-ati-6.9.0-38.fc10.x86_64
kernel-2.6.27.4-79.fc10.x86_64

Note You need to log in before you can comment on or make changes to this bug.