Bug 451392 - package depends on unsupported component
package depends on unsupported component
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-utils (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Robert Peterson
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-13 20:42 EDT by Marco Grigull
Modified: 2010-01-11 22:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-18 14:46:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Grigull 2008-06-13 20:42:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.12) Gecko/20080409 Red Hat/1.5.0.12-15.el5_1 Firefox/1.5.0.12

Description of problem:
GFS and associtated Utilities are production supported components.

GFS2 remains as a technology preview.

Installing gfs-utils pulls in gfs2-utils, which is not supported; so is gfs-utils supported or unsupported?

Version-Release number of selected component (if applicable):
gfs-utils.x86_64 0:0.1.17-1.el5

How reproducible:
Always


Steps to Reproduce:
1. system must be subscribed to cluster storage. e.g.: rhel-x86_64-server-cluster-storage-5

2.[root@aurum ~]# yum install gfs-utils.x86_64

Loading "rhnplugin" plugin

Loading "security" plugin

rhel-x86_64-server-5      100% |=========================| 1.4 kB    00:00     

rhel-x86_64-server-cluste 100% |=========================| 1.4 kB    00:00     

rhel-x86_64-server-cluste 100% |=========================| 1.4 kB    00:00     

rhel-x86_64-server-vt-5   100% |=========================| 1.4 kB    00:00     

rhn-tools-rhel-x86_64-ser 100% |=========================| 1.2 kB    00:00     

Setting up Install Process

Parsing package install arguments

Resolving Dependencies

--> Running transaction check

---> Package gfs-utils.x86_64 0:0.1.17-1.el5 set to be updated

--> Processing Dependency: gfs2-utils for package: gfs-utils

--> Running transaction check

---> Package gfs2-utils.x86_64 0:0.1.44-1.el5 set to be updated

--> Finished Dependency Resolution



Dependencies Resolved



=============================================================================

 Package                 Arch       Version          Repository        Size 

=============================================================================

Installing:

 gfs-utils               x86_64     0.1.17-1.el5     rhel-x86_64-server-cluster-storage-5  219 k

Installing for dependencies:

 gfs2-utils              x86_64     0.1.44-1.el5     rhel-x86_64-server-5  304 k



Transaction Summary

=============================================================================

Install      2 Package(s)         

Update       0 Package(s)         

Remove       0 Package(s)         



Total download size: 524 k

Is this ok [y/N]: y

Downloading Packages:

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing: gfs2-utils                   ######################### [1/2] 

  Installing: gfs-utils                    ######################### [2/2] 



Installed: gfs-utils.x86_64 0:0.1.17-1.el5

Dependency Installed: gfs2-utils.x86_64 0:0.1.44-1.el5

Complete!


3.[root@aurum ~]# rpm -qiR gfs-utils

Name        : gfs-utils                    Relocations: (not relocatable)

Version     : 0.1.17                            Vendor: Red Hat, Inc.

Release     : 1.el5                         Build Date: Fri 04 Apr 2008 02:35:37 AM EST

Install Date: Sat 14 Jun 2008 10:39:00 AM EST      Build Host: hs20-bc1-5.build.redhat.com

Group       : System Environment/Kernel     Source RPM: gfs-utils-0.1.17-1.el5.src.rpm

Size        : 509115                           License: GPL

Signature   : DSA/SHA1, Sat 19 Apr 2008 06:20:54 AM EST, Key ID 5326810137017186

Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>

URL         : http://sources.redhat.com/cluster/

Summary     : Utilities for managing the global filesystem (GFS)

Description :

The gfs-utils package contains a number of utilities for creating,

checking, modifying, and correcting any inconsistencies in GFS

filesystems.

/bin/bash  

/bin/sh  

/bin/sh  

/sbin/chkconfig  

/sbin/chkconfig  

gfs2-utils  

libc.so.6()(64bit)  

libc.so.6(GLIBC_2.2.5)(64bit)  

libc.so.6(GLIBC_2.3)(64bit)  

libc.so.6(GLIBC_2.3.4)(64bit)  

libc.so.6(GLIBC_2.4)(64bit)  

libncurses.so.5()(64bit)  

libvolume_id  

libvolume_id.so.0()(64bit)  

ncurses  

rpmlib(CompressedFileNames) <= 3.0.4-1

rpmlib(PartialHardlinkSets) <= 4.0.4-1

rpmlib(PayloadFilesHavePrefix) <= 4.0-1

rtld(GNU_HASH)  



Actual Results:
<inline>

Expected Results:
supported components should only rely on other supported componenets.  Unsupported components should be ommited by default.

Additional info:
The same goes for loading the current gfs kernel module; it cannot be loaded without the gfs2 module also loading...

[root@aurum ~]# uname -a

Linux aurum 2.6.18-92.1.1.el5xen #1 SMP Thu May 22 09:17:24 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

[root@aurum ~]# lsmod | grep gfs

[root@aurum ~]# modprobe gfs

[root@aurum ~]# lsmod | grep gfs

gfs                   305788  0 

gfs2                  525805  1 gfs

[root@aurum ~]# rmmod gfs2

ERROR: Module gfs2 is in use by gfs

[root@aurum ~]#
Comment 1 Robert Peterson 2008-06-16 16:21:45 EDT
For RHEL5.1 and 5.2, gfs and gfs2 use the same cluster infrastructure.
That's because they share a common lock protocol kernel module, lock_dlm
which calls dlm.  The specific components of that infrastructure (i.e.
lock_dlm and dlm itself) should, in my opinion, be supported.  The part
that isn't supported is the gfs2 file system kernel module. For future
releases (hopefully 5.3) the GFS and GFS2 infrastructures are being
separated out so this should not be an issue.
Comment 2 Robert Peterson 2008-06-18 14:46:42 EDT
This won't be an issue in 5.3 with the release of the bugs listed here:
https://bugzilla.redhat.com/show_bug.cgi?id=447748#c12

Note You need to log in before you can comment on or make changes to this bug.