Bug 451475 - Summary: SELinux is preventing mono (unconfined_mono_t) "unix_read unix_write" to <Unknown> (unlabeled_t).
Summary: SELinux is preventing mono (unconfined_mono_t) "unix_read unix_writ...
Status: CLOSED DUPLICATE of bug 450443
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-14 14:39 EDT by Gustavo Coutinho
Modified: 2008-06-14 17:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-14 17:32:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug alert (2.59 KB, text/plain)
2008-06-14 14:39 EDT, Gustavo Coutinho
no flags Details

  None (edit)
Description Gustavo Coutinho 2008-06-14 14:39:44 EDT
SELinux is preventing mono (unconfined_mono_t) "unix_read unix_write" to <Unknown>
(unlabeled_t).

Detailed Description:

SELinux denied access requested by mono. It is not expected that this access is
required by mono and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                unconfined_u:unconfined_r:unconfined_mono_t:s0-s0:
                              c0.c1023
Target Context                system_u:object_r:unlabeled_t:s0
Target Objects                None [ sem ]
Source                        mono
Source Path                   /usr/bin/mono
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           mono-core-1.9.1-2.fc9
Target RPM Packages           
Policy RPM                    selinux-policy-3.3.1-42.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain 2.6.25-14.fc9.i686 #1
                              SMP Thu May 1 06:28:41 EDT 2008 i686 i686
Alert Count                   1
First Seen                    Fri 13 Jun 2008 11:11:20 PM BRT
Last Seen                     Fri 13 Jun 2008 11:11:20 PM BRT
Local ID                      86e9a825-89e4-4a10-9d4b-d8d1b9a59f65
Line Numbers                  

Raw Audit Messages            

host=localhost.localdomain type=AVC msg=audit(1213409480.471:114): avc:  denied
 { unix_read unix_write } for  pid=32201 comm="mono" key=1291862093
scontext=unconfined_u:unconfined_r:unconfined_mono_t:s0-s0:c0.c1023
tcontext=system_u:object_r:unlabeled_t:s0 tclass=sem

host=localhost.localdomain type=SYSCALL msg=audit(1213409480.471:114):
arch=40000003 syscall=117 per=400000 success=no exit=-13 a0=2 a1=4d00404d a2=8
a3=180 items=0 ppid=1 pid=32201 auid=500 uid=500 gid=500 euid=500 suid=500
fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="mono"
exe="/usr/bin/mono"
subj=unconfined_u:unconfined_r:unconfined_mono_t:s0-s0:c0.c1023 key=(null)
Comment 1 Gustavo Coutinho 2008-06-14 14:39:44 EDT
Created attachment 309365 [details]
bug alert
Comment 2 Xavier Lamien 2008-06-14 17:32:28 EDT

*** This bug has been marked as a duplicate of 450443 ***

Note You need to log in before you can comment on or make changes to this bug.