Bug 45148 - binutils only set LC_MESSAGES, not other variables
Summary: binutils only set LC_MESSAGES, not other variables
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: binutils   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-20 15:15 UTC by Trond Eivind Glomsrxd
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-09 16:36:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Trond Eivind Glomsrxd 2001-06-20 15:15:06 UTC
Most programs in binutils only setlocale (LC_MESSAGES, ""); - as most
languages contain non-ASCII character, messages in these languages won't be
shown correctly, but have lots of embedded question marks.

To fix this, either add setlocale(LC_CTYPE,"") as well or change to
setlocale(LC_ALL) - the reason I'm not doing it is than I'm not familiar
enough with binutils to be sure this doesn't affect the produced binaries
in a negative way.

Comment 1 hjl 2001-10-09 16:36:52 UTC
Should be fixed in 2.11.92.0.5. See

http://sources.redhat.com/ml/libc-alpha/2001-10/msg00048.html

Comment 2 Jakub Jelinek 2001-10-11 16:04:06 UTC
Fixed in binutils-2.11.92.0.5-2.


Note You need to log in before you can comment on or make changes to this bug.