Bug 451492 - Update gnome-do to 0.5
Summary: Update gnome-do to 0.5
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-do
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Sindre Pedersen Bjørdal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 453845
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-14 21:39 UTC by Valent Turkovic
Modified: 2008-08-03 13:41 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2008-08-03 13:41:35 UTC


Attachments (Terms of Use)

Description Valent Turkovic 2008-06-14 21:39:32 UTC
Description of problem:
If it doesn't breal the universe and Fedora dependencies please update gnome-do
to 0.5 version.

Cheers.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Sindre Pedersen Bjørdal 2008-06-15 07:10:55 UTC
0.5 Requires an updated gtk-sharp2, gnome-sharp and gnome-desktop-sharp. Untill
that happens, you'll have to stick with 0.4. Sorry.

Comment 2 Valent Turkovic 2008-06-18 09:03:06 UTC
Is it updated in rawhide to 0.5?

Can you please just give me advice if you would recomment me to go and ask that
gtk-sharp2 and others get updated or is something you don't recomment I try?

Comment 3 Mario Chacon 2008-06-23 20:29:24 UTC
Hi
Do you plan to add this update ?

How can i help you to do it?

Salu2..

Comment 4 Otto Rey 2008-06-23 20:34:19 UTC
Mario, you can help us "comiendole el matambre a el satanico Dr. Low" :D

Comment 5 Otto Rey 2008-06-23 20:38:18 UTC
Please, ignore comment #4 ... just bad copy/paste....

Comment 6 Mario Chacon 2008-06-29 18:11:54 UTC
Hi
Do you plan to add this update ?

How can i help you to do it?

Salu2..

Comment 7 David Nielsen 2008-06-29 18:59:45 UTC
file bugs against the required components and get those maintainers to input on
such updates and their impact, then make this bug block on those bug reports.

It's likely to be a lot of work.. oh and don't double post please.

Comment 8 Steven Garrity 2008-07-01 17:46:47 UTC
If I try to build 0.5, I get stuck looking for gnome-keyring-sharp. Is this part
of another package, or something stand-alone?

Comment 9 Mario Chacon 2008-07-02 17:16:44 UTC
Could you install gnome-keyring-devel?

Could you install gnome-desktop-sharp-2.0 package?
 I am standing on that step...

Salu2...


Comment 10 Alex Lancaster 2008-07-05 01:38:30 UTC
(In reply to comment #9)
> Could you install gnome-keyring-devel?
> 
> Could you install gnome-desktop-sharp-2.0 package?
>  I am standing on that step...

Unfortunately it appears that gnome-desktop-sharp has not yet been submitted for
review as a Fedora package and that gnome-sharp has been prematurely updated in
rawhide (and initally submitted to F-9 via bodhi) to 2.20 because it moved a
number of features (such as gtkhtml) to gnome-desktop-sharp which doesn't exist yet.



Comment 11 Alex Lancaster 2008-07-11 11:33:48 UTC
Could gnome-do 0.5 please be build for rawhide, it's still causing broken deps:

	gnome-do-0.4.2.0-2.fc10.i386 requires mono(gconf-sharp) = 0:2.16.0.0

This is particularly well overdue because the whole reason the mono breakage
happened because gnome-sharp was bumped to 2.20 in order for gnome-do to be
updated to 0.5!!

If other packages (other than gnome-sharp and gnome-desktop-sharp) need to be
updated as well to allow gnome-do to be updated 0.5, please consider contacting
those maintainers and get them to update.  At this point we can't go backwards
to the old gnome-sharp 2.16 in rawhide, so we may as well go forwards and clean
up the mess it created...

Comment 12 Mario Chacon 2008-07-11 18:15:17 UTC
Sorry bother him, but as I have no answer for updating these library I was
trying to compile gnome-0.5, I have no other option but to wait for updates.

Comment 13 Sindre Pedersen Bjørdal 2008-07-12 10:03:49 UTC
Sorry for the inconvience caused by gnome-do in the last weeks. I was the only 
maintainer and I'm currently away on holiday. I have however, succeeded in 
getting a co-maintainer who should be able to update the package soon. If not, 
I'll have a go at it myself when I get back. 

Comment 14 Mario Chacon 2008-07-13 01:26:10 UTC
Yeah!..Thanks for all men!, when you return from your holidays?

Comment 15 Mario Chacon 2008-07-13 01:35:11 UTC
Sorry for ask it again, but the problem to update gnome-do isn't it the update
and dependency of the version of the library gnome-sharp?

Comment 16 Alex Lancaster 2008-07-13 01:43:48 UTC
(In reply to comment #15)
> Sorry for ask it again, but the problem to update gnome-do isn't it the update
> and dependency of the version of the library gnome-sharp?

gnome-sharp *has* been updated to 2.20 but only in rawhide, not F-9.  When
rawhide is sorted out and the fallout from the soname bump is completely
resolved then we can consider a bump in F-9, which may not happen if the
potential breakage is considered to be worse than the benefits of updating. 
(i.e. updating a large portion of mono stack for a single optional package may
not be feasible/desirable). 

Comment 17 Sindre Pedersen Bjørdal 2008-08-03 13:41:35 UTC
0.5 now in Rawhide. Please report any issues. As noted above, Fedora 9 update won't happen unless we can do it smoothly, at the moment it doesn't look like we can. Closing this as WONTFIX, please re-open if conditions for a gnome-sharp somehow become smoother.


Note You need to log in before you can comment on or make changes to this bug.