Bug 451497 - Version dependency problem in eclipse-mylyn
Version dependency problem in eclipse-mylyn
Product: Fedora
Classification: Fedora
Component: eclipse-mylyn (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-06-14 20:25 EDT by Michel Alexandre Salim
Modified: 2009-08-18 05:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-08-18 05:28:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screenshot of failed installation process (52.02 KB, image/png)
2008-06-14 20:25 EDT, Michel Alexandre Salim
no flags Details

  None (edit)
Description Michel Alexandre Salim 2008-06-14 20:25:34 EDT
Description of problem:
Attempting to install the beta version of the Scala plugin from scala-lang.org,
which depends on Mylyn, triggers the following error:

Mylyn Bridge: PDE, CVS and Ant (2.3.2.v20080402-2100) requires plug-in
"org.eclipse.mylyn.tasks.core (2.3.0)", or compatible

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. yum install eclipse-mylyn\*
2. install Scala plugin: http://www.scala-lang.org/downloads/scala-plugin-beta/
Actual results:
Error message described

Expected results:
Should work

Additional info:
The summaries for -ide, -java and -pde could perhaps be made more descriptive.
Comment 1 Michel Alexandre Salim 2008-06-14 20:25:34 EDT
Created attachment 309379 [details]
Screenshot of failed installation process
Comment 2 Andrew Overholt 2008-06-23 12:15:42 EDT
AFAICT all of the Mylyn plugins have this in META-INF/MANIFEST.MF:


meaning they should accept 2.3.2.  Is there perhaps a deeper error here?  The
update manager in Eclipse <= 3.3.x doesn't properly expose plugins that are in
/usr/lib (these are arch-specific plugins called "fragments").  This upstream
bug has not been fixed and sometimes 3rd party plugins like this Scala plugin
depend upon something that is arch-specific.

Have you thought about packaging this for Fedora?  It's not hard and I wouldn't
mind helping you out.
Comment 3 Michel Alexandre Salim 2008-07-15 15:54:14 EDT
(Sorry for the late reply, was watching the status which is still NEW)

I've thought of packaging -- will Fedora 10 have Eclipse 3.4? In that case I
might just package the next version of the plugin, which requires that.

The Scala plugin bundles its own copy of Scala; is that the norm for
Eclipse-related packages or would I have to patch it to use a standalone
Comment 4 Andrew Overholt 2008-07-15 16:50:07 EDT
Yes, Fedora 10 will have Eclipse 3.4.

The Fedora guidelines specify that there should only be one copy of things on
the system so you'd have to patch it to use the system Scala.
Comment 5 John Poelstra 2008-10-18 22:26:11 EDT
Can this bug be considered resolved?
Comment 6 Andrew Overholt 2008-10-20 09:10:49 EDT
Comment 7 Bug Zapper 2008-11-25 21:25:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
Comment 8 Alexander Kurtakov 2009-08-18 05:28:46 EDT
No response from reporter for 8 months. Additionally it was reported against F-9.

Note You need to log in before you can comment on or make changes to this bug.