Bug 451551 - During hibernate / resume percentage progress is missing [NEEDINFO]
During hibernate / resume percentage progress is missing
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vokal
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2008-06-15 13:07 EDT by JanS
Modified: 2016-06-20 09:45 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-20 09:45:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
poelstra: needinfo? (mjg)


Attachments (Terms of Use)

  None (edit)
Description JanS 2008-06-15 13:07:31 EDT
Description of problem:

  On Fedora 6 I had nice percentage progress status while hibernating. When I
have installed Fedora 8 and 9 this status dissapeared! Only blank screen left.

This is very annoying as I have no idea what is going on, if system hangs, or if
it is hibernating properly. And I have no clue when it will finish.

Same thing when awaking, resuming, I have no clue when it will wake up. Dont
know if I should wait or forget about it and reset my computer. 

As hibernating takes really long time a status bar or even some communicates are
very important.



Version-Release number of selected component (if applicable):
  Fedora 9 an Fedora 8, from the release till now
eg. Linux 2.6.25.3-18.fc9.x86_64
    pm-utils  1.1.0-7.fc9
    

How reproducible:
  allways same behaviour

Steps to Reproduce:
1. hibernate
2. look onto screen
3. see nothing, no progress bar
  
Actual results:
  Nothing is on the screen. Blank screen, with cursor blinking on left upper corner.

Expected results:
  Should be a percentage status or progress bar (when hibernating and when resuming)


Additional info:
  my hardware:
HP Compaq nx7400
Graphic card: Intel 945GM
Comment 1 Richard Hughes 2008-06-16 07:48:16 EDT
Yes, we are able to do this properly when we have plymouth and kernel
modesetting - this is scheduled as a feature for F10.
Comment 2 JanS 2008-06-26 15:29:46 EDT
But for now it doesn't have to be done "properly".
The graphical boot or any change of mode is not required for printing texts like:
10%
11%
12%
etc...

And such text-based progress indication will do the job.
In Fedora 10, 11, etc, maybe it could be swiched to graphical mode, but for now,
the main issue (lack of information) can be solved simpler.
Comment 3 Richard Hughes 2008-06-30 09:13:43 EDT
Matthew is working upstream to see how we can print the percentage bar with the
quiet option turned on.
Comment 4 Matthew Garrett 2008-06-30 09:24:36 EDT
There's two options. First, we could change the loglevel on suspend and restore
it on resume. The downside to this is that we'd also end up with a large
quantity of debug spew. The second approach would be to alter the loglevels of
the progress printing. This would work fine, but is arguably incorrect - I'm not
sure of its upstreamability.
Comment 5 John Poelstra 2008-08-14 16:23:47 EDT
(In reply to comment #1)
> Yes, we are able to do this properly when we have plymouth and kernel
> modesetting - this is scheduled as a feature for F10.

Changing version to rawhide since it sounds like the issue occurs there too.  

Is this bug still targeted for being fixed in F10?  Just wondering if I should add to one of the F10 trackers?
Comment 6 Michael Monreal 2009-02-28 15:39:34 EST
(In reply to comment #5)
> Is this bug still targeted for being fixed in F10?

I guess not :) But it would be very nice to have for F11. 
With KMS being supported on AMD/Intel and experimental for NVidia, this makes sense now I think. Would improve usability and give some extra polish.
Comment 7 Phil Knirsch 2009-04-10 15:45:52 EDT
Won't make it before Tuesday, so dropping for F11 and aiming for F12.

Thanks & regards, Phil
Comment 8 JanS 2009-04-11 05:46:19 EDT
It was since Fedora 8 when I haven't seen any indication what's going on during hibernation and resume.
It is long time, and bug is really uncomfortable. I don't know if system hangs or is working, and I should wait or unplug. And when hibernation takes few minutes it is really stressing. 
Please give us any indication of what's going on, any workaround. 
Even increasing kernel debug level would be good in this situation, I am not afraid of text messages, but I am afraid of living in the darkness.
I could use any, even ugly solution.
Comment 9 Sebastian Krämer 2010-01-19 14:42:33 EST
Since plymouth has matured and KMS has come along to work on many machines these days (and probably will even improve with nouveau progressing), how about this bug?
I too think that at least /some/ progress would be good to have even if it's not eye candy-ish. Hibernation with today's RAM dimensions can take time and watching some progress makes people feel good :)

What about the needinfo? flag? What info is needed?
Comment 10 Sebastian Krämer 2011-05-29 02:45:50 EDT
I think the progress indication isn't part of the vanilla kernel and Fedora won't have it, right? Why not just close this bug report?

Don't get me wrong, I'd love to see functional and graphical improvements to suspend/hibernate or even tuxonice support, I just don't think it's going to happen if upstream doesn't do it.
Comment 11 Josh Boyer 2012-03-28 14:01:00 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.

Note You need to log in before you can comment on or make changes to this bug.