Bug 451588 - Review Request: ghc-unix-compat - Portable POSIX-compatibility layer for GHC Haskell
Review Request: ghc-unix-compat - Portable POSIX-compatibility layer for GHC ...
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
Depends On:
Blocks: 451589
  Show dependency treegraph
Reported: 2008-06-15 22:09 EDT by Rajesh Krishnan
Modified: 2010-01-25 18:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-17 19:23:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
ghc-unix-compat- (3.65 KB, text/plain)
2008-06-15 22:09 EDT, Rajesh Krishnan
no flags Details

  None (edit)
Description Rajesh Krishnan 2008-06-15 22:09:01 EDT
Version-Release number of selected component (if applicable):

Steps to Reproduce:
1.  Download 
    to rpmbuild/SOURCES folder.
2.  Copy attached <this-package>-<this-version>.spec to rpmbuild/SPECS folder.
3.  Copy the attached *.patch files to the rpmbuild/SOURCES folder (if any).
3.  Execute:
rpmbuild --clean  --target=$(uname -i) -ba \
Actual results:

Expected results:
1. You should see the compiled RPM and SRPM binaries in the respective 
2. After installing the RPM package, you should be able to import the relevant 
$ ghci
ghci>  :m + <module-name-from-package>

Additional info:
1. The same .SPEC should work for Fedora 9 also (I guess, but I tested only on 
Comment 1 Rajesh Krishnan 2008-06-15 22:09:01 EDT
Created attachment 309431 [details]
Comment 2 Bryan O'Sullivan 2008-06-17 19:23:28 EDT
I am mass-closing these submissions, as they are completely useless and do not
follow any of the packaging guidelines.  Do not attempt to reopen them.

Note You need to log in before you can comment on or make changes to this bug.