Bug 4516 - File Locking Broken
File Locking Broken
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: nfs-server (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-13 16:52 EDT by Steve Wills
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-27 20:07:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Wills 1999-08-13 16:52:47 EDT
My mail client (mutt, running on 6.0) is unable to lock my
mailbox files (mbox format) across NFS from a 6.0 NFS
server.

Steve
Comment 1 Cristian Gafton 1999-08-27 20:07:59 EDT
are you running lockd and statd on the client machine? Locking over
NFS is evil anyway and it is useless anyway, since it is anything
*but* atomic. Use imap.

Or come by my desk and show me a reproductible scenario so I can dig
into the problem.

------- Additional Comments From   08/30/99 12:35 -------
I actually managed to get this working by using the "lock" option to
mount.

Sorry,
Steve

Note You need to log in before you can comment on or make changes to this bug.