Bug 45166 - RFE: mount with dev permissions
Summary: RFE: mount with dev permissions
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-20 18:51 UTC by Gerald Teschl
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-24 13:05:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2001-06-20 18:51:33 UTC
I really like the way pam_console sets the permissiond on, e.g., /dev/fd0.
However, i'd like to use autofs for my floppy and then the permissions
won't help since autofs runs as root and hence a floppy is mounted
with owner root. Hence I currently use a little script to change
a uid=...,gid=... option in the automounter map each time a user logs in
via X
(i.e., I added the following to /etc/X11/xdm/GiveConsole
----------------------------
MYUID=`id -u $USER`
MYGID=`id -g $USER`
sed "s/uid=[0-9]*/uid=$MYUID/g;s/gid=[0-9]*/gid=$MYGID/g" /etc/auto.mnt >
/etc/auto.mnt.
mv -f /etc/auto.mnt. /etc/auto.mnt
---------------------------
and a similar line to /etc/X11/xdm/TakeConsole) However, I think the right
thing(TM) to do this would be by adding this feature to pam_console...

Comment 1 Gerald Teschl 2001-06-20 18:52:59 UTC
See also bug #20410

Comment 2 Nalin Dahyabhai 2001-08-31 02:43:49 UTC
The pam_console module probably isn't the right place for this -- it only has a
chance to do its thing when you log in, and you'd want this to be done whenever
the filesystem is mounted.  This leads me to believe that this should either be
an autofs feature, or a generic flag given to mount (something like the uid=
flags, but in a "use the device's owner/group instead of the current user/group"
sense).

Comment 3 Gerald Teschl 2002-02-17 16:32:06 UTC
I guess you are right, the right place would be mount. I'll
transfere this bug to mount.

Comment 4 Elliot Lee 2004-06-03 18:05:05 UTC
Realistically, this feature is most likely to be implemented by
someone sending in a patch...

Comment 5 Karel Zak 2005-10-24 13:05:31 UTC
Please, send this request to upstream developer(s). This is not right place for
requests like this one. Thanks.


Note You need to log in before you can comment on or make changes to this bug.