Bug 451667 - xpvm segfaults when not enough args given
xpvm segfaults when not enough args given
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pvm (Show other bugs)
4.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-16 11:37 EDT by Milos Malik
Modified: 2008-06-19 14:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-19 14:32:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2008-06-16 11:37:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
The xpvm program does not check if parameters "-M" and "-N" are followed by some arguments.

Version-Release number of selected component (if applicable):
pvm-gui-3.4.5-11

How reproducible:
Always


Steps to Reproduce:
1. start an X session and execute following commands in an X terminal
2. xpvm -M
3. xpvm -N

Actual Results:
2 segmentation faults.

Expected Results:
No segmentation faults. 2 error messages about missing arguments.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.