This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 451672 - [RFE] include static loadkeys
[RFE] include static loadkeys
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kbd (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Vitezslav Crhonek
:
Depends On:
Blocks: 229865
  Show dependency treegraph
 
Reported: 2008-06-16 12:16 EDT by David Lehman
Modified: 2009-01-20 16:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:05:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build and package a statically linked loadkeys binary (904 bytes, patch)
2008-06-16 12:16 EDT, David Lehman
no flags Details | Diff

  None (edit)
Description David Lehman 2008-06-16 12:16:09 EDT
Description of problem:
We are introducing support for installation to encrypted (LUKS) block devices in
RHEL5.3. This means mkinitrd will need to support decryption of encrypted root
and swap devices, which means collecting passphrases via keyboard input. This in
turn leads to a requirement that the system keymap be loaded prior to this
keyboard input. Since the version of mkinitrd used in the RHEL5 stream does not
support dynamically linked binaries, we will need a static loadkeys for this
purpose.

Version-Release number of selected component (if applicable):
kbd-1.12-20.el5

Additional info:
I'm attaching a patch to kbd.spec to accomplish the above. It is probably not
the most elegant approach, but it seems to do the job.
Comment 1 David Lehman 2008-06-16 12:16:09 EDT
Created attachment 309514 [details]
build and package a statically linked loadkeys binary
Comment 2 RHEL Product and Program Management 2008-06-16 12:30:27 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2009-01-20 16:05:24 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0218.html

Note You need to log in before you can comment on or make changes to this bug.