Bug 451697 - evolution hangs up when switching to calendar view
evolution hangs up when switching to calendar view
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-16 14:47 EDT by Peter Janakiev
Modified: 2008-06-20 05:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-20 05:37:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Janakiev 2008-06-16 14:47:08 EDT
Description of problem: I cannot switch to calendar view


Version-Release number of selected component (if applicable):
evolution-2.22.2-2.fc9.x86_64


How reproducible:
always

Steps to Reproduce:
1.start evolution 
2.press the calendar button or select from menu
3.
  
Actual results:
nothing happens and evolution becomes idle/not responsible


Expected results:
to switch to the calendar view

Additional info:
the main window does not appear if I start it with 
 evolution --component=calendar
/home/malwk/.themes/All/gtk-2.0/scrolls/scrollbar.rc:83: Unable to locate image
file in pixmap_path: "scrollbar_horizontal.png"
/home/malwk/.themes/All/gtk-2.0/scrolls/scrollbar.rc:87: Background image
options specified without filename
CalDAV Eplugin starting up ...
RSS Plugin enabled
RSS Plugin enabled
** (evolution:7695): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:7695): DEBUG: mailto URL program: evolution
(evolution:7695): e-data-server-DEBUG: Loaded default categories

the other views work okay
Comment 1 Milan Crha 2008-06-17 04:16:59 EDT
If I got it right, then when you run evolution in a mail, for example, and then
switch to calendar component, then it hangs and is unresponsive? Or can you
switch back to other component from the calendar one? If it just hang, can you
attach gdb to the evolution process and paste here the result of "thread apply
all bt" command from gdb? Thanks in advance.
Comment 2 Peter Janakiev 2008-06-18 19:00:56 EDT
After I press the calendar view the whole interface freezes. I cannot switch
back, yet the application is not killed, i have to kill it via the window
manager. I will try this with a brand new account. With same account settings i
cannot duplicate it on i386 (i have make a back up of the evolution settings
(via evolution menu) and imported to x86_64 laptop. 
I seem to not make something as I should in dbg as when i type thread apply all
bt i get 
thread apply all bt
[Thread 0x4172b950 (LWP 21060) exited]
[Thread 0x44369950 (LWP 21043) exited]
[Thread 0x43968950 (LWP 21059) exited]

Program terminated with signal SIGKILL, Killed.
some debug packages I have to install?
Comment 3 Milan Crha 2008-06-19 04:52:11 EDT
Please verify that you've installed debug info packages for evolution,
evolution-data-server, gtkhtml and if you use, then also evolution-exchange.

I guess the command in gdb wasn't processed because it was still running the
application. You can hit Ctrl+C to stop it, or even better, just run evolution
on the console and when it freezes, then on the other console attach gdb to the
evolution process with 'gdb evolution pid', where pid is the process identifier
of the running evolution.
Comment 4 Peter Janakiev 2008-06-20 05:36:33 EDT
I have installed the debug packages with yum.

And i cannot duplicate  it any more after the install. I have removed the
installed packages but still i cannot duplicate it. So I am closing it. If it
shows up again I will try the advised manner to collect info and I will submit
it here. 

Note You need to log in before you can comment on or make changes to this bug.