Bug 451770 - Cannot create bridged network for paravirtualized guest.
Cannot create bridged network for paravirtualized guest.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-17 05:56 EDT by James Sella
Modified: 2008-08-29 07:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-29 07:14:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Sella 2008-06-17 05:56:01 EDT
+++ This bug was initially created as a clone of Bug #386151 +++

Description of problem:
I cannot create a bridged network connection using either virt-manager or
virt-install.  Virt-manager does not allow me to specify a shared interface
(paravirtualized guest) - the space contains no choices.  When I try to create
the guest using virt-install, I specify --network briege:eth0 and get hotplug
errors of this type: 
can't add vif1.0 to bridge eth0: Operation not supported


Version-Release number of selected component (if applicable):
xen-3.1.0-8.fc7.i386
libvirt-0.3.3-1.fc7.i386



How reproducible:
Always happens.

Steps to Reproduce:

1.  virt-install -p -n fed8p -r 1000 -f /var/lib/xen/images/fed8p -s 8 -l
http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/i386/os/
--os-type=linux --os-variant=generic26 --network bridge:eth0
2.  Follow the installation sequence until the network setting step.  Specify
dhcp and the boot will hang (and then return to the network set up question)
3.
  
Actual results:
Guest installation cannot get past the network set up question.

Expected results:
Normal installation

Additional info:

-- Additional comment from moose@quadruped.com on 2007-11-15 21:40 EST --
Created an attachment (id=260681)
xend log of failed installation due to network problem


-- Additional comment from moose@quadruped.com on 2007-11-15 21:50 EST --
Created an attachment (id=260701)
virt-install log of guest create that fails with network problem.


-- Additional comment from moose@quadruped.com on 2007-11-16 07:52 EST --
I should note that this is the i386 version of Fedora 7 running on x86_64
hardware (a Dell Precision 690).  I see this problem regardless of SELinux
setting (I'
ve tried enforcing, permissive, and disabled - albeit without any reboots
between attempts).

-- Additional comment from moose@quadruped.com on 2007-11-16 22:30 EST --
Created an attachment (id=262081)
Xend log from rebooted system reveals network bridge errors

I rebooted my machine and examined the xend log.  Please note the errors
indicating failures to create network bridges.	What do I have to do to avoid
these?	Is this a known problem with Fedora 7, a problem with my platform, or
some obscure configuration error?

-- Additional comment from sella@digital-genesis.com on 2008-03-23 18:18 EST --
I've run into this issue on both Fedora 7 and Fedora 8. In both cases, it only
happens after I update the system with yum. It appears to be an issue with dbus
or how virt-manager works with it.

Using virt-manager to create new bridged Xen virtual machines works fine after a
fresh install. After I use yum to update the system I'm no longer able to create
virtual machines with bridged interfaces. Specifically, in virt-manager on the
"Connect to a Host" screen, the "Shared physical device" option has an empty
drop down for "device".

Below is a fix that worked for me with Fedora 8 (didn't try Fedora 7):

On the updated system, as root, mount the install DVD and change to the
directory containing your original set of RPMs ("Packages" with Fedora 8,
"Fedora" with Fedora 7), then reinstall the old RPMs for dbus, dbus-libs and
dbus-x11.

Example:

# cd /media/disk/Packages
# rpm -Uvh --oldpackage dbus-1.1.2-7.fc8.x86_64.rpm 
dbus-libs-1.1.2-7.fc8.x86_64.rpm dbus-libs-1.1.2-7.fc8.i386.rpm
dbus-x11-1.1.2-7.fc8.x86_64.rpm

*NOTE: You may need to specify other packages if RPM complains about dependencies.

This fix is very similar to one mentioned for RHES5.1 here:

http://www.linuxquestions.org/questions/linux-enterprise-47/virt-manager-in-rhel5.1-has-empty-shared-physical-device-list-625390/

There is also mention of the same issue in CentOS-5, which they resolve by
patching /usr/share/virt-manager/virtManager/connection.py. Description and
patch is here:

http://bugs.centos.org/view.php?id=2516
Comment 1 James Sella 2008-06-17 05:57:15 EDT
Bug was closed under Fedora 7. Cloned bug to re-open for Fedora 8.
Comment 2 Doug Chapman 2008-06-24 12:17:11 EDT
This is not ia64, that is likely why it was never addressed.  Moving to i386
since it appears that is what the user was using.
Comment 3 Daniel Berrange 2008-08-29 07:14:32 EDT
This was a DBus issue exposing a bug in virt-manager, long since addressed in an update

Note You need to log in before you can comment on or make changes to this bug.