Bug 451789 - [CRM#1825054] Enable support for GLX in Xvnc
[CRM#1825054] Enable support for GLX in Xvnc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: vnc (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Tkac
:
Depends On:
Blocks: 391501
  Show dependency treegraph
 
Reported: 2008-06-17 09:09 EDT by Alan Matsuoka
Modified: 2013-04-30 19:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:16:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vnc-4.1.2-9crm1825054.el5.src.rpm (6.56 MB, application/x-rpm)
2008-06-17 09:09 EDT, Alan Matsuoka
no flags Details
sosreport (2.47 MB, application/x-bzip2)
2008-06-17 09:12 EDT, Alan Matsuoka
no flags Details
vnc-crm1825054.spec (22.42 KB, text/plain)
2008-06-17 09:12 EDT, Alan Matsuoka
no flags Details
vnc-crm1825054.spec.patch (3.26 KB, text/x-patch)
2008-06-17 09:13 EDT, Alan Matsuoka
no flags Details
vnc-xorg-x11-server-1.1.1-mesa-6.5.1.patch (2.02 KB, patch)
2008-06-17 09:13 EDT, Alan Matsuoka
no flags Details | Diff
vnc-xorg-x11-server-1.1.1-selinux-awareness.patch (1.51 KB, patch)
2008-06-17 09:13 EDT, Alan Matsuoka
no flags Details | Diff

  None (edit)
Description Alan Matsuoka 2008-06-17 09:09:14 EDT
General Escalation Information

State the problem

  1. Provide time and date of the problem
  
  The problem was reported in CRM #1825054 on 06-May-2008
  
  2. Provide clear and concise problem description as it is understood at the
time of escalation
         * Observed behavior
        
         Using Xvnc, the GLX extension is not available.
        
         * Desired behavior

         The GLX extension should be available.
        
  3. State specific action requested of SEG
  
  Analyse the proposed patch (attached) and escalate in Bugzilla if appropriate.
  
  4. State whether or not a defect in the product is suspected
  
  The problem does not lie in Xvnc, but rather in the build of the rpm package
for vnc-server.
  
  According to the patches already included in the src.rpm, GLX should be
enabled. This can be verified by looking at the patch "vnc-opengl.patch" which
reads:
  
      -#define BuildGlxExt NO
      +#define BuildGlxExt YES

  Unfortunately, this is not sufficient to enable GLX in the build of the
Xserver in Xvnc. This is because in RHEL5, we are using mesa 6.5.1 with Xorg 7.1
and Xorg requires some additional patches to be able to build against this
version of Mesa. The required patches are included in the "regular" Xorg build
(ie "xorg-x11-server") but these patches were not included in the vnc package.
  
  The attached patches are described hereafter:
  
  - vnc-xorg-x11-server-1.1.1-mesa-6.5.1.patch
  
  This patch modifies the build procedure of the Xserver (included in vnc for
Xvnc) so it can make use of Mesa 6.5.1 that ships with RHEL5 - This patch is
based on a similar patch for the "xorg-x11-server" package on RHEL5, slightly
modified.
  
  - vnc-xorg-x11-server-1.1.1-selinux-awareness.patch
  
  Enabling Mesa requires another patch for SELinux awareness. This patch is
similar to the one that comes with "xorg-x11-server".
  
  - vnc-crm1825054.spec.patch
  
  This is for the spec file, applying the two previous patches at build time.
Please note that GLX should not be enabled on some architecture (namely s390
s390x ppc64, that was already the case previously)
  
         * Provide Bugzilla if one already exists
        
  There is BZ#185442 - "CRM 805548: [Synopsis] OpenGL support for Xvnc
(vnc-server)" but the resolution seems incomplete due to the reasons exposed above.
  
Provide supporting info

  1. State other actions already taken in working the problem:

  Check in BZ, but the patch is not sufficient to enable GLX in Xvnc.

Hi,

Customer has now confirmed that the patch does indeed enable GLX in Xvnc and
works as expected.

He also gave the following justification for the need of GLX in Xvnc:

" I view the missing GLX suppport as a bug, I can't see any reason why it
shouldn't be there. To us it's very critical. To run time computationally
demending and time consuming CFD/CAE optimization on server using vnc is the
best solution we have found. We recommend it to our customers and I'm sure it's
used by many people. [...]"

Cheers,
Olivier.

  2. Attach sosreport
  
  3. Attach other supporting data

  N/A

  4. Provide issue repro information:

  Run Xvnc :1 -ac
  run xterm -display :1
  Check glxinfo, there is no GLX support.

  5. List any known hot-fix packages on the system
  
  None.
  
  6. List any customer applied changes from the last 30 days
  
  None.

RHEL specific
Note - A core file should be uploaded to a test system whether it is a kernel
core or from some other component.

  1. Provide core file (if one is involved) and state:
  
  No core, there is no crash involved.

  2. Provide the base and kernel info output from ''checksysreport''

   #######     Kernel info      ########
   kernel-2.6.18-53.1.13.el5 (rhel-x86_64-client-5)
   https://rhn.redhat.com/network/software/packages/details.pxt?pid=432805
   Unsupported modules:
     vmnet
     vmblock
     vmmon
   All modules appears genuine
   Kernel not up2date (should be kernel-2.6.18-92.el5-x86_64)
Comment 1 Alan Matsuoka 2008-06-17 09:09:16 EDT
Created attachment 309609 [details]
vnc-4.1.2-9crm1825054.el5.src.rpm
Comment 2 Alan Matsuoka 2008-06-17 09:12:01 EDT
Created attachment 309610 [details]
sosreport
Comment 3 Alan Matsuoka 2008-06-17 09:12:45 EDT
Created attachment 309611 [details]
vnc-crm1825054.spec
Comment 4 Alan Matsuoka 2008-06-17 09:13:04 EDT
Created attachment 309612 [details]
vnc-crm1825054.spec.patch
Comment 5 Alan Matsuoka 2008-06-17 09:13:19 EDT
Created attachment 309613 [details]
vnc-xorg-x11-server-1.1.1-mesa-6.5.1.patch
Comment 6 Alan Matsuoka 2008-06-17 09:13:36 EDT
Created attachment 309614 [details]
vnc-xorg-x11-server-1.1.1-selinux-awareness.patch
Comment 7 Adam Tkac 2008-06-17 09:35:40 EDT
Yes, patches are already included in F7 >= and work well. I don't see any
problem with GLX enabled
Comment 12 Colin.Simpson 2008-10-01 10:03:29 EDT
Can you release this version as an update to RH5? Maybe even RH4
Comment 13 Adam Tkac 2008-10-01 10:43:01 EDT
(In reply to comment #12)
> Can you release this version as an update to RH5? Maybe even RH4

Yes, update is going to be part of RHEL 5.3 . You can test it if you are interested but this is not official release. It is only for testing purposes: http://people.redhat.com/atkac/vnc-4.1.2-12.el5.src.rpm
Comment 14 Chanon Owen 2008-11-03 13:37:15 EST
Are there any plans to place this update in RH4?
Comment 15 Adam Tkac 2008-11-12 06:06:41 EST
(In reply to comment #14)
> Are there any plans to place this update in RH4?

No, we are not going to enable GLX in RHEL4
Comment 17 errata-xmlrpc 2009-01-20 16:16:03 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0119.html

Note You need to log in before you can comment on or make changes to this bug.