Bug 451804 - kernel: KERNEL: assertion (flags & MSG_PEEK) failed at net/ipv4/tcp.c (1354)
kernel: KERNEL: assertion (flags & MSG_PEEK) failed at net/ipv4/tcp.c (1354)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-17 10:16 EDT by Eugene Kanter
Modified: 2008-10-14 15:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.6.26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 15:01:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vv (29.57 KB, application/octet-stream)
2008-08-13 23:43 EDT, Andrew Alm
no flags Details
my output of lspci -vv with Atheros Communications Inc. AR5212 802.11abg NIC (11.67 KB, text/plain)
2008-08-14 15:29 EDT, Erik Streb del Toro
no flags Details

  None (edit)
Description Eugene Kanter 2008-06-17 10:16:47 EDT
Description of problem:

Using following wireless pcmcia card

kernel: ath5k_pci 0000:02:00.0: registered as 'phy0'
kernel: ath5k phy0: Atheros AR2413 chip found (MAC: 0x78, PHY: 0x45)

on SONY VIAO PCG-F590 laptop.

configured NFS server and attempted to copy large file into the system. the
speed is very slow. many assertion messages in the log:

kernel: recvmsg bug: copied CEDBCDF6 seq CEDBD39E
kernel: KERNEL: assertion (flags & MSG_PEEK) failed at net/ipv4/tcp.c (1354)

As soon as opened firefox and attempted to file a bug (while NFS transfer was
active) the kernel hung (caps lock and scroll lock LED blink). Tried several times.

Version-Release number of selected component (if applicable):

kernel-2.6.25.6-55.fc9.i686

How reproducible:

always

Steps to Reproduce:

see description.
Comment 1 Andrew Alm 2008-08-13 23:43:16 EDT
Created attachment 314279 [details]
lspci -vv
Comment 2 Andrew Alm 2008-08-13 23:45:20 EDT
I just started experiencing this problem today on a Thinkpad T61 (also ath5k driver).  I am not sure what triggered it (a download possibly), but I am getting the same messages as Eugene Kanter posted.  I roughly estimate those two messages to be repeated in /var/log/messages about 5000 times a second (before I stopped rsyslog my /var/log/messages file was 3.4GB).  I am attaching lscpi -vv output.  Is there any other output I should supply?

uname -a
Linux thinktank 2.6.25.11-97.fc9.x86_64 #1 SMP Mon Jul 21 01:09:10 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux
Comment 3 Erik Streb del Toro 2008-08-14 15:29:31 EDT
Created attachment 314345 [details]
my output of lspci -vv   with Atheros Communications Inc. AR5212 802.11abg NIC

seems that the bug comes from the Atheros Communications Inc. AR5212 802.11abg NIC because the other bugreporter has the same NIC
Comment 4 Erik Streb del Toro 2008-08-14 15:30:52 EDT
(In reply to comment #2)
> I just started experiencing this problem today on a Thinkpad T61 (also ath5k
> driver).  I am not sure what triggered it (a download possibly), but I am
> getting the same messages as Eugene Kanter posted.  I roughly estimate those
> two messages to be repeated in /var/log/messages about 5000 times a second
> (before I stopped rsyslog my /var/log/messages file was 3.4GB).  I am attaching
> lscpi -vv output.  Is there any other output I should supply?
> 
> uname -a
> Linux thinktank 2.6.25.11-97.fc9.x86_64 #1 SMP Mon Jul 21 01:09:10 EDT 2008
> x86_64 x86_64 x86_64 GNU/Linux

I’m having the same problem since some days with another notebook from IBM — the X40. My /var/log/messages file is 1,3 GB big.

I’m seeing the problem every time after booting my notebook and logging into Gnome Desktop. As long as I don’t deactivate my wireless network by rightclicking the network-manager icon, the system remains super slow. My memory is used up to 1,4 GB and my swap file is used up to 800 MB. After deactivating the wireless network and waiting for another minute or so, the system comes back to normal speed and the memory frees again.

uname -a
Linux femto.dd27.org 2.6.25.14-108.fc9.i686 #1 SMP Mon Aug 4 14:08:11 EDT 2008 i686 i686 i386 GNU/Linux

See bugs:
‣ http://kerneltrap.org/mailarchive/linux-ath5k-devel/2008/6/4/2028874http://www.spinics.net/lists/netdev/msg66196.html
Comment 5 Erik Streb del Toro 2008-10-09 17:18:06 EDT
I don’t see the error anymore. Don’t know since when it is gone, but at least since one month.

Note You need to log in before you can comment on or make changes to this bug.