Bug 451850 - Allow non-GNOME default session in gdm
Allow non-GNOME default session in gdm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-06-17 15:32 EDT by Warren Togami
Modified: 2015-01-14 18:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-08 17:26:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2008-06-17 15:32:42 EDT
daemon/gdm-session-direct.c:

static char *
get_fallback_session_name (void)
{
        const char  **search_dirs;
        int           i;
        char         *name;

        name = g_strdup ("gnome");
        if (get_session_command_for_name (name, NULL)) {
                return name;
        }

The hard coded "gnome" here makes it impossible to specify any other session as
default globally for the system.  Ray Strode mentioned that it should grab this
from the /etc/gdm/custom.conf.

Could we have this in a F-9 update as well?
Comment 1 jmccann 2008-06-17 15:38:53 EDT
So, while I expect we'd take a patch to change this it won't help you if the
user has already selected a session.  The session stored in the .dmrc will
always override this default.
Comment 2 Warren Togami 2008-06-17 17:38:56 EDT
> So, while I expect we'd take a patch to change this it won't help you if the
> user has already selected a session.  The session stored in the .dmrc will
> always override this default.

This is fine.

Since we'll be changing this part, perhaps we could discuss alternative ideas.

I would prefer an optional system-wide dmrc that is read before user's dmrc (so
other DM's could read it from the common location).  But Ray and Jon said that
some "IPA" based thing should be providing this in the future.  They don't want
to add a global dmrc now because they plan on eliminating all .dmrc's.

What exactly is this future thing?  Are any details of it written down anywhere?
 How soon will we have it?
Comment 3 Simo Sorce 2008-07-12 10:53:44 EDT
Not sure why I am needinfo here, changing to assigned as I have no knowledge of
internal GDM stuff.
Comment 4 Matthias Clasen 2008-10-01 20:31:54 EDT
I believe this is more or less fixed by the splitting off of gnome-session-xsession.
It is now possible to use gdm without installing the file 
/usr/share/xsessions/gnome.desktop. In that case, the fallback code mentioned in this report won't return gnome, but instead find the first desktop file in /usr/share/xsessions.
Comment 5 Matthias Clasen 2008-10-08 17:26:55 EDT
Considering this fixed, since no further input was provided.

Note You need to log in before you can comment on or make changes to this bug.