Bug 451887 - No direct rendering on intel 945GM with duel head
No direct rendering on intel 945GM with duel head
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-17 19:07 EDT by louisgtwo
Modified: 2008-06-20 12:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-20 12:03:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log (21.59 KB, text/plain)
2008-06-17 19:07 EDT, louisgtwo
no flags Details
log with updated udev and /dev/dri/card0 present (31.12 KB, text/plain)
2008-06-19 14:11 EDT, louisgtwo
no flags Details
Log with working dri. Single monitor and no xorg.conf file (25.16 KB, text/plain)
2008-06-19 15:08 EDT, louisgtwo
no flags Details
Log without dri. duel monitor and xorg.conf file (21.68 KB, text/plain)
2008-06-19 15:14 EDT, louisgtwo
no flags Details
my xorg.conf file (867 bytes, text/plain)
2008-06-19 15:15 EDT, louisgtwo
no flags Details
Duel head config (818 bytes, text/plain)
2008-06-19 15:45 EDT, louisgtwo
no flags Details

  None (edit)
Description louisgtwo 2008-06-17 19:07:54 EDT
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)

Direct Rendering is disabled on F9 with current updates.
Comment 1 louisgtwo 2008-06-17 19:07:54 EDT
Created attachment 309679 [details]
xorg log
Comment 2 louisgtwo 2008-06-17 19:23:52 EDT
I just noticed /dev/drm does not exist on my box.
Comment 3 Adam Jackson 2008-06-19 13:38:20 EDT
That's a shame.  And I blame udev.
Comment 4 louisgtwo 2008-06-19 14:09:15 EDT
ok I updated udev to 124-1.fc9.1 from updates-testing and now have
/dev/dri/card0 I still do not have dri enabled.
Comment 5 louisgtwo 2008-06-19 14:11:07 EDT
Created attachment 309868 [details]
log with updated udev and /dev/dri/card0 present
Comment 6 louisgtwo 2008-06-19 15:06:30 EDT
This seems to be another duel head config problem with the latest server update
for f9. If I run X without a xorg.conf file and only the laptop monitor I have
direct rendering. When I use xorg.conf file with a vga monitor attached there is
no direct rendering.
Comment 7 louisgtwo 2008-06-19 15:08:23 EDT
Created attachment 309870 [details]
Log with working dri. Single monitor and no xorg.conf file
Comment 8 louisgtwo 2008-06-19 15:14:29 EDT
Created attachment 309873 [details]
Log without dri. duel monitor and xorg.conf file
Comment 9 louisgtwo 2008-06-19 15:15:50 EDT
Created attachment 309874 [details]
my xorg.conf file
Comment 10 louisgtwo 2008-06-19 15:45:34 EDT
Created attachment 309876 [details]
Duel head config
Comment 11 louisgtwo 2008-06-19 22:11:08 EDT
without an xorg.conf file dri works and I have two monitors but mirrors of each
other. I need to have them spanning but when I use the xorg.conf file I have
problems. System-config-display gives me errors when I use it.
Comment 12 louisgtwo 2008-06-19 23:03:40 EDT
I have pinpointed the problem to the virtual 3200 1200 line in the xorg.conf
file. Without this line the two displays are brought up with direct rendering
enabled. But the displays are lot aligned correctly. I need to have the virual
fb bigger. 
Comment 13 louisgtwo 2008-06-20 00:20:03 EDT
I just read that the 3D engine has an 11 bit coordinate space at one point
making it impossible to draw to areas beyond 2048x2048. So I guess this is not
possible for this hardware.

I will close this bug.
Comment 14 Matěj Cepl 2008-06-20 12:03:20 EDT
Thanks for letting me know.

Note You need to log in before you can comment on or make changes to this bug.