Bug 451913 - Automate generation of FOP configuration files
Automate generation of FOP configuration files
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
high Severity high
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-17 23:12 EDT by Jeff Fearn
Modified: 2010-11-23 23:18 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.34
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-23 01:35:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2008-06-17 23:12:38 EDT
Currently there are separate fop files (conf, font metrics) for each version of
FOP and each version of the O/S. These files need to be created when publican is
built instead of being pre-generated.

Supported O/S: rhel4, rhel5, fc9, rawhide
Supported FOP: 0.20, 0.95beta

Files that need auto-generation:
 1. fop.conf
 2. font-metrics/*.xml (one per font)
 3. pickfont.xsl (needs xsl:import in pdf.xsl)

pickfont.xsl needs to override these templates:
 1. pickfont-sans
 2. pickfont-serif
 3. pickfont-mono

Spec file needs to be able to set the correct Requires and BuildRequires for
each O/S.

FOP 0.20 support will be dropped for O/S >= rhel5 since FOP 0.95beta has been
built in brew.

FOP has not been built for epel4 or epel5 so integration needs to be disabled
for those builds until FOP is available in those repositories.
Comment 1 Jeff Fearn 2008-06-23 01:35:44 EDT
Added script to generate FOP font-metrics files and fop.xconf file at build time.

Note You need to log in before you can comment on or make changes to this bug.