Bug 451917 - can't update the configuration
can't update the configuration
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
0.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: space02
  Show dependency treegraph
 
Reported: 2008-06-18 00:33 EDT by Deependra Singh Shekhawat
Modified: 2009-09-17 02:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 02:59:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deependra Singh Shekhawat 2008-06-18 00:33:40 EDT
Description of problem:
When I logged in into the WebUI for the first time after creation of the account
I was asked to continue with configuring the other configuration options inside 
https://server/rhn/admin/config/GeneralConfig.do
And when I pressed update button it said
An error occurred and your satellite configuration changes could not be stored.
When I looked into /var/log/secure I found this

server sudo:   tomcat : sorry, you must have a tty to run sudo ;
TTY=unknown ; PWD=/usr/share/tomcat5 ; USER=root ; 
COMMAND=/usr/bin/rhn-config-satellite.pl
--target=/etc/rhn/rhn.conf
--option=server.satellite.http_proxy_username= 
--option=server.satellite.http_proxy= --option=mount_point=/var/satellite 
--option=kickstart_mount_point=/var/satellite
--option=server.satellite.http_proxy_password= 2>&1 > /dev/null

Looks like it's trying to run the command via sudo but TTY is not set.

Thanks
Deependra Singh Shekhawat
Comment 1 Clifford Perry 2008-06-23 18:47:12 EDT
The Spacewalk server should have both config entries within it, along with I
assume apache running as apache user, and tomcat5 running as tomcat user. 

http://git.fedorahosted.org/git/?p=spacewalk.git;a=tree;f=satellite/install/Spacewalk-Setup/share;h=3653c26b6fb5e8903cb0acc727cbed9056df3c65;hb=master

	sudoers.base
	sudoers.rhn

If this content is missing, then I would expect it to fail. Since the installer
was recently modified, if could be a bug not putting the content into
/etc/sudoers correctly. (or change in sudo in F9 compared to RHEL 4). 

Cliff. 
Comment 2 Milan Zazrivec 2008-08-04 09:18:26 EDT
Following two lines need to be present in /etc/sudoers for the things to work
properly (i.e. apache and tomcat users being able to run stuff via sudo even
without a real tty):

Defaults:tomcat !requiretty
Defaults:apache !requiretty
Comment 3 Milan Zazrivec 2008-08-04 11:42:41 EDT
Fix commited to git: 54a22bab4bfe3273b8c84417d79b331c14ac4589
Comment 4 Devan Goodwin 2008-09-03 11:07:36 EDT
Verified against spacewalk 0.2.

Sep  3 11:03:29 dhcp77-172 sudo:   tomcat : TTY=unknown ; PWD=/usr/share/tomcat5 ; USER=root ; COMMAND=/usr/bin

/rhn-config-satellite.pl --target=/etc/rhn/rhn.conf --option=server.satellite.http_proxy_username=admin --optio

n=server.satellite.http_proxy= --option=server.satellite.http_proxy_password= 2>&1 > /dev/null
Comment 5 Miroslav Suchý 2009-09-17 02:59:16 EDT
Spacewalk is released for long time.

Note You need to log in before you can comment on or make changes to this bug.