Bug 451943 - postgresql-8.2.9-1.fc8.src.rpm does not build as root
postgresql-8.2.9-1.fc8.src.rpm does not build as root
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-18 05:45 EDT by Danilo Marcucci
Modified: 2013-07-02 23:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 09:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File log (424.10 KB, text/plain)
2008-06-18 05:45 EDT, Danilo Marcucci
no flags Details

  None (edit)
Description Danilo Marcucci 2008-06-18 05:45:13 EDT
Description of problem:
postgresql-8.2.9-1.fc8.src.rpm not builded

Version-Release number of selected component (if applicable):
8.2.9-1

How reproducible:
rpmbuild --define "dist .fc8" --define "fedora 8" --rebuild --target i686
/usr/src/redhat/SRPMS/postgresql-8.2.9-1.fc8.src.rpm

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Not builded

Expected results:
Builded postgresql-8.2.9-1.fc8.i686.rpm

Additional info:
postgresql-8.2.9-1.fc8.src.rpm.log created with these parameter:
rpmbuild --define "dist .fc8" --define "fedora 8" --rebuild --target i686
/usr/src/redhat/SRPMS/postgresql-8.2.9-1.fc8.src.rpm 2>&1 | tee -a
postgresql-8.2.9-1.fc8.src.rpm.log
Comment 1 Danilo Marcucci 2008-06-18 05:45:13 EDT
Created attachment 309710 [details]
File log
Comment 2 Tom Lane 2008-06-18 09:56:49 EDT
Well, you didn't provide the critical log file:

pg_regress: initdb failed
Examine ./log/initdb.log for the reason.

but my guess based on the paths is that you tried to do the build as root.  Postgres refuses (quite 
properly) to run as root, so you either have to do the build as non-root or skip the regression tests (--
define='runselftest 0').  Personally I never build RPMs as root, and it's generally Red Hat policy not to.
Comment 3 Danilo Marcucci 2008-07-15 09:20:16 EDT
I have try to rebuild with this option "--define='runselftest 0'" and the pakage
its rebuilded correctly.
If you want you can close this "bug" as resolved.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.