Bug 451954 - [a11y] Switching mail -> calendar, evolution crashes.
[a11y] Switching mail -> calendar, evolution crashes.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-06-18 07:20 EDT by sangu
Modified: 2008-10-21 11:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 01:05:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 530776 None None None Never

  None (edit)
Description sangu 2008-06-18 07:20:24 EDT
Description of problem:
$ gdb evolution

Program received signal SIGSEGV, Segmentation fault.
0x054bd8f5 in spi_atk_bridge_signal_listener (signal_hint=0xbfffef9c, 
    n_param_values=3, param_values=0xbffff068, data=0x80c4d88) at bridge.c:1160
1160	      if (ATK_IS_OBJECT (child))

(gdb) bt
#0  0x054bd8f5 in spi_atk_bridge_signal_listener (signal_hint=0xbfffef9c, 
    n_param_values=3, param_values=0xbffff068, data=0x80c4d88) at bridge.c:1160
#1  0x0118a283 in signal_emit_unlocked_R (node=0x80b12b8, detail=0, 
    instance=0x85f2ea0, emission_return=0x0, instance_and_params=0xbffff068)
    at gsignal.c:2406
#2  0x0118bf16 in IA__g_signal_emit_valist (instance=0x85f2ea0, signal_id=110, 
    detail=0, var_args=0xbffff2e0 "d\222x\aL���\b���a�m\a�._\b")
    at gsignal.c:2199
#3  0x0118c273 in IA__g_signal_emit_by_name (instance=0x85f2ea0, 
    detailed_signal=0x1af1792 "children_changed") at gsignal.c:2267
#4  0x01ae7c47 in idle_dates_changed (data=0x85f2ea0) at ea-cal-view.c:283
#5  0x076dd161 in g_idle_dispatch (source=0x8a06008, callback=0x80af688, 
    user_data=0x85f2ea0) at gmain.c:4168
#6  0x076df081 in IA__g_main_context_dispatch (context=0x8098800)
    at gmain.c:2063
#7  0x076e25db in g_main_context_iterate (context=0x8098800, block=1, 
    dispatch=1, self=0x806b6e8) at gmain.c:2696
#8  0x076e2aaa in IA__g_main_loop_run (loop=0x80eaff8) at gmain.c:2919
#9  0x00b829e3 in bonobo_main () at bonobo-main.c:311
#10 0x08060a53 in main (argc=1, argv=0xbffff564) at main.c:783

$ dmesg | grep evolution
evolution[2966]: segfault at 8508458b ip 013118f5 sp bf9e18c0 error 4 in
libatk-bridge.so[130e000+6000]
evolution[21903]: segfault at 8508458b ip 084708f5 sp bfbf8690 error 4 in
libatk-bridge.so[846d000+6000]
evolution[23531]: segfault at 1 ip 00278bec sp bff36bc0 error 4 in
libevolution-a11y.so.0.0.0[270000+15000]

Version-Release number of selected component (if applicable):
2.23.4-1.fc10

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
at-spi-1.23.3-1.fc10.i386
Comment 1 Matthew Barnes 2008-07-08 11:00:55 EDT
Accessibility related.  Is this reproducible at all?
Comment 2 sangu 2008-07-08 23:48:38 EDT
(In reply to comment #1)
> Accessibility related.  Is this reproducible at all?

Your comment is right.  After disabling Assitive Technologies, this problem
doesn't happen.
Comment 3 Orlando Arias 2008-08-05 14:38:43 EDT
On my system (patched to latest updates) Evolution does not crash when switching to calendar mode (from any place, I might add), it just freezes on the spot and I have to SIGKILL it.
Comment 4 Matthew Barnes 2008-10-20 14:59:40 EDT
Crash reported upstream at [1].  I can also easily reproduce the crash with Evolution 2.24.0 and accessibility turned on.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=530776
Comment 5 Matthias Clasen 2008-10-21 01:05:34 EDT
I've put a patch into at-spi to make it survive this kind of abuse, but really, evo should be fixed to emit this signal properly.
Comment 6 Matthew Barnes 2008-10-21 11:30:00 EDT
Upstream bug has a patch that comments out the bad signal emission.  Oddly, the code causing this crash has been lurking in Evolution since 2003.

Note You need to log in before you can comment on or make changes to this bug.