Bug 452002 - Eclipse crashes after update to firefox-3.0-1
Eclipse crashes after update to firefox-3.0-1
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-18 12:13 EDT by Thomas Diesler
Modified: 2015-03-02 09:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:07:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
thomas.diesler: needinfo-


Attachments (Terms of Use)
bugreport (36.22 KB, text/plain)
2008-06-18 12:13 EDT, Thomas Diesler
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 236724 None None None Never

  None (edit)
Description Thomas Diesler 2008-06-18 12:13:55 EDT
Description of problem:

Eclipse-3.3.2 crashes with attached bug report

Version-Release number of selected component (if applicable):

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Removing:
 xulrunner               i386       1.9-1.fc9        installed          21 M
Removing for dependencies:
 firefox                 i386       3.0-1.fc9        installed          11 M

How reproducible:

eclipse crashes immediately after selecting a workspace or during code completion.


Workaround:

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 firefox                 i386       3.0-0.60.beta5.fc9  fedora            8.5 M
Installing for dependencies:
 xulrunner               i386       1.9-0.60.beta5.fc9  fedora            8.9 M
Comment 1 Thomas Diesler 2008-06-18 12:13:55 EDT
Created attachment 309751 [details]
bugreport
Comment 2 Colin Walters 2008-06-18 14:25:22 EDT
Hi, can you see:
http://fedoraproject.org/wiki/StackTraces
and install the necessary debuginfo packages to get a complete stack trace?

(By Fedora 10 this should not be necessary)

Comment 3 Thomas Diesler 2008-06-18 15:22:10 EDT
What are the "necessary debuginfo packages"? If you could give me a series of
yum commands that I need to execute to install them that would help.
Comment 4 Thomas Diesler 2008-06-18 15:22:41 EDT
Here is the related forum post:
http://forums.fedoraforum.org/showthread.php?p=1032776#post1032776
Comment 5 Colin Walters 2008-06-18 15:35:14 EDT
From
http://fedoraproject.org/wiki/StackTraces#What_are_debuginfo_rpms.2C_and_how_do_i_get_them.3F

debuginfo-install firefox
debuginfo-install eclipse-jdt

Should get you set up.
Comment 6 Jan Vlug 2008-07-02 16:21:45 EDT
See also: https://bugs.eclipse.org/bugs/show_bug.cgi?id=236724
Comment 7 Matěj Cepl 2008-07-28 18:45:02 EDT
There is apparently fix in the upstream Eclipse, but probably not for our
version of Eclipse. 

Reassigning to Eclipse component, so that the patch may be considered for
backporting or something.
Comment 8 Kent Sebastian 2008-07-29 10:55:04 EDT
I am running Fedora 9 32-bit with the following packages:

firefox-3.0.1-1.fc9.i386
xulrunner-1.9.0.1-1.fc9.i386
eclipse-platform-3.3.2-12.fc9.i386

and I can't reproduce the crash. 

The upstream bug report seemed to address a 32-bit/64-bit issue. 

Is the reporter seeing this on x64_64 machine (with 32-bit eclipse)? Please
provide the output of rpm -q firefox xulrunner eclipse-platform.

Thanks.
Comment 9 Bug Zapper 2009-06-09 21:41:29 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-07-14 12:07:07 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.