Bug 452032 - xulrunner-1.9 missing buildreq of cairo >= 1.6.0 and lcms-devel >= 1.17
xulrunner-1.9 missing buildreq of cairo >= 1.6.0 and lcms-devel >= 1.17
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-18 16:11 EDT by Matthew Miller
Modified: 2009-01-14 09:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 09:56:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2008-06-18 16:11:56 EDT
The spec file for xulrunner-1.9-1 says:


%define cairo_version 0.5
BuildRequires:  cairo-devel >= %{cairo_version}

but in trying to rebuild it on CentOS 5, I get an error:

checking for cairo >= 1.6.0 freetype2 fontconfig... Requested 'cairo >= 1.6.0' b
ut version of cairo is 1.2.4


Looks like that 0.5 needs to be bumped.
Comment 1 Matthew Miller 2008-06-18 16:37:57 EDT
Also, lcms-devel >= 1.17
Comment 2 Martin Stransky 2009-01-14 09:56:35 EST
added to rawhide

Note You need to log in before you can comment on or make changes to this bug.