Bug 452032 - xulrunner-1.9 missing buildreq of cairo >= 1.6.0 and lcms-devel >= 1.17
Summary: xulrunner-1.9 missing buildreq of cairo >= 1.6.0 and lcms-devel >= 1.17
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xulrunner
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-18 20:11 UTC by Matthew Miller
Modified: 2009-01-14 14:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-14 14:56:35 UTC
Type: ---


Attachments (Terms of Use)

Description Matthew Miller 2008-06-18 20:11:56 UTC
The spec file for xulrunner-1.9-1 says:


%define cairo_version 0.5
BuildRequires:  cairo-devel >= %{cairo_version}

but in trying to rebuild it on CentOS 5, I get an error:

checking for cairo >= 1.6.0 freetype2 fontconfig... Requested 'cairo >= 1.6.0' b
ut version of cairo is 1.2.4


Looks like that 0.5 needs to be bumped.

Comment 1 Matthew Miller 2008-06-18 20:37:57 UTC
Also, lcms-devel >= 1.17

Comment 2 Martin Stransky 2009-01-14 14:56:35 UTC
added to rawhide


Note You need to log in before you can comment on or make changes to this bug.