Bug 452060 - host program segfaults when looking up IPv6-only host
host program segfaults when looking up IPv6-only host
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 473297 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-18 21:47 EDT by J. Randall Owens
Modified: 2013-04-30 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 21:51:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
host ipv6.ghiapet.net core dump (7.21 MB, application/octet-stream)
2008-06-23 07:35 EDT, J. Randall Owens
no flags Details
output of host -D ipv6.example.com (3.71 KB, text/plain)
2008-06-30 07:15 EDT, J. Randall Owens
no flags Details
core dump from host -D (7.21 MB, application/octet-stream)
2008-06-30 07:17 EDT, J. Randall Owens
no flags Details
output of host -D ipv6.example.com when it didn't segfault (4.62 KB, text/plain)
2008-06-30 07:25 EDT, J. Randall Owens
no flags Details
host -D google.com 127.0.0.1 (2.06 KB, text/plain)
2009-01-09 08:49 EST, Jakub Hrozek
no flags Details

  None (edit)
Description J. Randall Owens 2008-06-18 21:47:59 EDT
Description of problem:
When I was checking on my IPv6 setup, I created an IPv6-only record in named for
my main host (AAAA only, no A record), and tried looking it up with `host
ipv6.example.com`.  Quite a few times, I ran it, and it would return the
expected "ipv6.example.com has IPv6 address 2001:5c0:xxx::1" (I'm using
substitutions, of course), but then the next line would say "Segmentation fault".

I was checking it by looking up some external IPv6-only hosts, and then some of
my other local hosts, and none of them produced segfaults.  And now, if I try
`host ipv6.example.com` again, it no longer segfaults.  So, I can't include a
backtrace yet.  Perhaps after the next reboot, whenever that is.

Version-Release number of selected component (if applicable):
bind-utils-9.5.0-32.rc1.fc9.i386

How reproducible:
Not clear, but it might involve having a host with only an AAAA record, and
looking it up.

Steps to Reproduce:
1. Install bind-utils
2. Create a DNS record (ipv6.example.com) with only an AAAA entry
3. `host ipv6.example.com`
  
Actual results:
ipv6.example.com has IPv6 address 2001:5c0:xxx::1
Segmentation fault

Expected results:
ipv6.example.com has IPv6 address 2001:5c0:xxx::1
Comment 1 Adam Tkac 2008-06-23 05:59:30 EDT
Hm, works fine on my machine. Would it be possible attach core file, please?

$ ulimit -c unlimited
$ host ipv6

and then attach core.XXXX file. Thanks
Comment 2 J. Randall Owens 2008-06-23 07:35:07 EDT
Created attachment 310021 [details]
host ipv6.ghiapet.net core dump

I'll just assume you meant `limit coredumpsize unlimited`; I'm a tcsh kind of
guy.
Much to my surprise, host even produced a core dump the first time.
If I need to install bind-debuginfo for a better core, just give the word.
Oh, note that if the information is in that core but seems different from what
you see in my public DNS, it is from an internal DNS server.
Comment 3 Adam Tkac 2008-06-30 06:36:22 EDT
(In reply to comment #2)
> Much to my surprise, host even produced a core dump the first time.
> If I need to install bind-debuginfo for a better core, just give the word.

Debuginfo doesn't improve "core quality". Core is always same.

Would it be possible run host with -D parameter and attach output, please? (you
can also attach next core to ensure that you don't hit different problem) Thanks
Comment 4 J. Randall Owens 2008-06-30 07:15:07 EDT
Created attachment 310573 [details]
output of host -D ipv6.example.com
Comment 5 J. Randall Owens 2008-06-30 07:17:23 EDT
Created attachment 310574 [details]
core dump from host -D
Comment 6 J. Randall Owens 2008-06-30 07:25:00 EDT
Created attachment 310575 [details]
output of host -D ipv6.example.com when it didn't segfault

The first time I ran with -D, I'd forgotten to change the coredumpsize, but it
didn't segfault that time anyway; it seems quite random.  It occurred to me
that it might be helpful to have the output from that for comparison, so here
it is if it helps at all.
Comment 7 Adam Tkac 2008-12-02 03:48:49 EST
*** Bug 473297 has been marked as a duplicate of this bug. ***
Comment 8 Adam Tkac 2008-12-02 04:23:53 EST
Could anyone retest this bug with proposed fix, please? Download appropriate distro/arch from links written below.

Fedora 9:
https://kojiweb.fedoraproject.org/koji/taskinfo?taskID=970322

Fedora 10:
https://kojiweb.fedoraproject.org/koji/taskinfo?taskID=970335

Thanks
Comment 9 Jakub Hrozek 2008-12-02 07:25:44 EST
(In reply to comment #8)
> Could anyone retest this bug with proposed fix, please? Download appropriate
> distro/arch from links written below.

That seems much better! The previous version used to segfault in, like, 50% of queries, the new one survived 100 queries in a loop..

Thanks!
Comment 10 Adam Tkac 2008-12-03 07:24:37 EST
(In reply to comment #9)
> 
> That seems much better! The previous version used to segfault in, like, 50% of
> queries, the new one survived 100 queries in a loop..

Thanks for feedback, fix will be included in next update.
Comment 11 Fedora Update System 2009-01-08 10:39:08 EST
bind-9.5.1-1.P1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/bind-9.5.1-1.P1.fc9
Comment 12 Jakub Hrozek 2009-01-09 08:49:13 EST
Created attachment 328545 [details]
host -D google.com 127.0.0.1

As requested by developer, attaching the output of "host -D google.com 127.0.0.1". By visual comparison, it's very similar to what the original reporter attached..
Comment 13 Fedora Update System 2009-01-14 21:51:17 EST
bind-9.5.1-1.P1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.