Bug 452097 - Subpackage ntp to split out perl scripts
Subpackage ntp to split out perl scripts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-19 07:43 EDT by Chris Lalancette
Modified: 2008-07-28 07:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-28 07:11:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to subpackage ntp auxiliary perl scripts (2.16 KB, patch)
2008-06-19 07:43 EDT, Chris Lalancette
no flags Details | Diff

  None (edit)
Description Chris Lalancette 2008-06-19 07:43:20 EDT
Description of problem:
The oVirt project (http://ovirt.org) uses Fedora as the basis for building a
very small distribution (< 64MB compressed).  As part of that process, we
currently break the NTP perl dependency by just "rpm -e --nodeps perl". 
However, we prefer not to break rpm dependencies wherever possible.  Since NTP
only seems to use perl for two small auxiliary scripts, I propose subpackaging
those two scripts (with the associated man pages) into an ntp-perl package. 
That way we can use the main ntp package without perl for our small
distribution, and Fedora can continue to have the auxiliary scripts in the
subpackage.

I'm attaching a spec file patch (against what is currently in ntp/devel) that
does this; please consider for Fedora 10.
Comment 1 Chris Lalancette 2008-06-19 07:43:20 EDT
Created attachment 309844 [details]
Patch to subpackage ntp auxiliary perl scripts
Comment 2 Miroslav Lichvar 2008-06-19 08:09:08 EDT
Good idea, will be in the next release. Thanks.
Comment 3 Chris Lalancette 2008-06-21 08:36:52 EDT
Great, thanks for the quick response.

Chris Lalancette
Comment 4 Alan Pevec 2008-06-23 05:44:59 EDT
Just one thing, you don't need:
+%exclude %{_sbindir}/ntp-wait
+%exclude %{_sbindir}/ntptrace
+%exclude %{_mandir}/man8/ntptrace.8*

since there's an explicit list w/o wildcards in %files sections for each
sub-package.
Comment 5 Miroslav Lichvar 2008-07-28 07:11:35 EDT
Fixed in ntp-4.2.4p4-7.fc10.

Note You need to log in before you can comment on or make changes to this bug.