Bug 452130 - message throttling (queue)
message throttling (queue)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.0
All Linux
urgent Severity medium
: 1.1.1
: ---
Assigned To: Andrew Stitcher
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-19 11:16 EDT by Sergei Vorobiev
Modified: 2009-01-15 16:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-15 16:25:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergei Vorobiev 2008-06-19 11:16:55 EDT
message broker should allow for throttling the maximum rate of messages
submitted to a specific queue
Comment 1 Andrew Stitcher 2009-01-15 14:52:16 EST
I dont' think this is possible using the current protocol as there is no way to "push back" from messages going into a queue to the producer connection/session sending the messages, due to the exchange routing abstraction in the middle.

This feature is mooted for AMQP 1.0
Comment 2 Carl Trieloff 2009-01-15 16:25:21 EST
Only need session/connection level flow control for now

closing

Note You need to log in before you can comment on or make changes to this bug.