Bug 452134 - Regarding Virtual Machine
Regarding Virtual Machine
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.2
All Linux
low Severity urgent
: rc
: ---
Assigned To: Cole Robinson
Don Domingo
http://www.hclinfosystems.in
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-19 11:24 EDT by certification
Modified: 2008-12-03 00:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 00:26:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
from -- /etc/Xen/Guest (492 bytes, text/plain)
2008-07-08 09:10 EDT, certification
no flags Details

  None (edit)
Description certification 2008-06-19 11:24:16 EDT
Probleb Regarding Virtual Machine.

In virtual machine CDROM Drive is sensing but we unable to access or mount any 
cdrom.

While doing certification CDROM test also enables but it gets failes always 
because CDROM drive is unable access.

Kernel Version 2.6.18-92
OD RHEL 5.2 
Test kit version :hts5.2
Comment 1 certification 2008-06-23 07:52:51 EDT
Dear Team,

Problem Regarding Virtual Machine.

In virtual machine CDROM Drive is sensing but we unable to access or mount any 
cdrom.

While doing certification CDROM test also enables but it gets fails always 
because CDROM drive is unable to access.

Kernel Version 2.6.18-92
OS RHEL 5.2 
Test kit version :hts5.2

Please help us to solve this problem.

Regards,

P.Ramanujam
Comment 3 Christopher Curran 2008-06-24 21:08:09 EDT
This bug is unlikely a bug for the Virtualization Guide. I suspect this bug
belongs to another component, most likely Xen or libvirt.
Comment 4 certification 2008-06-24 23:37:02 EDT
Dear Team,

Yes. This is belongs Xen / Libvert.
How to solve this problem.
Please help.

Regards.
Ramanujam
Comment 5 certification 2008-06-30 02:00:45 EDT
Dear TEam,

Still we have the same issue please help us to solve this issue

Ramanujam
Comment 7 certification 2008-07-08 04:41:00 EDT
Dear Team,

In virtual machine we unable to access CDROM.
While we try to do certification with RHEL5.2 it is enables CDROM test also so 
this CDROM test gets always fail.
Please help us to solve this issue.
Kernel Version 2.6.8.92
hts version hts-16
Regards
Ramanujam
Comment 8 Daniel Berrange 2008-07-08 05:36:57 EDT
Please provide your guest config file from /etc/xen/GUEST-NAME and the XML
config from 'virsh dumpxml GUEST-NAME' while the guest is running.
Comment 9 certification 2008-07-08 09:10:27 EDT
Created attachment 311262 [details]
from   -- /etc/Xen/Guest

I have attached /etc/xen/guest file for your reference

Regards
Ramanujam
Comment 10 certification 2008-07-08 09:12:22 EDT
Dear Team,

I have attached /etc/xen/guest file from xen kernel.
Please help me solve this issue shortly.

Ragards
Ramanujam
Comment 11 Cole Robinson 2008-07-15 11:58:18 EDT
I'm a bit confused what the problem is. Please explain the exact process you are
using to create the guest. What distro is in the guest?

If you are using virt-manager or virt-install please provide 'virsh dumpxml
GUESTNAME'.

Also, what exactly is the error message you are seeing? Are you trying to
install the guest off a cdrom, or just trying to mount the cdrom in an existing
guest?

From the xm config file your provided above, it looks like you are trying to run
a guest with /var/lib/xen/images/guest.img: is guest.img a bootable cdrom? Is it
just a RHEL 5.2 boot.iso, or some other iso that we can easily obtain to try and
reproduce this bug?
Comment 12 Narayanan 2008-07-16 00:30:51 EDT
Dear Team,

Now i will explain the exact problem.

Problem 1
=========
I am using RHEL5.2 Kernel Version is 2.6.8-92

I created Virtual machine There also i used RHEL5.2 i mean in Virtual OS also 
RHEL5.2.

After succesfull installaation i could able to see CDROM appearing in COMPUTER.

I mean CDROM is appearing in virtual OS. this feature is not availabel in 
earlier version of RHEL5.2.

Than i tried to use CDROM in Virtual machine. I put a CD in CDROM and i tried 
to read the content. But i can not do that Because CDROM is not mounting in 
Virtual OS.

My exact problem is why i unable to use CDROM in Virtual OS.

Please help me to Solve this issue.

I want to use CDROM in Virtual OS.

Problem 2
=========
 Now i am doing certification in RHEL5.2 in all the systems.
while i tried to do certification in Virtual machine CDROM always gets fail 
because of above said problem.

Please help to solve this issue also.

This is common issue in all systems so it si common issue.

Kernel version i used Kernel 2.6.8-92.el5
Test tool version     hts 5.2-16

I hope i could explain

Regards 
P.Ramanujam
Comment 13 Anuj Verma (Kevin) 2008-07-16 01:59:37 EDT
All, 

This is to confirm that as of now CDROM test under FV GuestOS is not a
requirement for HW Certification. 

Red Hat HwCert team does not include FV CDROM test in catalog test-plan
requirement, hence HCL can ignore the same even if HTS tools adds CDROM to the
HTS-plan for system under certification. 

Kevin Verma 
Comment 14 Anuj Verma (Kevin) 2008-12-03 00:26:51 EST
Dear HCL Team, 

You were pointed out that bugzilla is not a support and interaction tool, I am closing this bug. 
Please use assistance guidelines as described in Hardware Certification Policy. 
(https://hardware.redhat.com/doc/sect-Hardware_Certification_Policy_Guide-Introduction-Requests_for_Assistance.html) 

Regards,
Kevin Verma

Note You need to log in before you can comment on or make changes to this bug.