Bug 452280 - bash on console (i.e., tty1) doesn't honor arrow keys for editing
bash on console (i.e., tty1) doesn't honor arrow keys for editing
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-20 13:38 EDT by Horst H. von Brand
Modified: 2014-01-12 19:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-24 08:24:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2008-06-20 13:38:00 EDT
Description of problem:
On tty1, bash doesn't consider arrow keys at all. I guess this is bash's fault,
but that is just a guess (perhaps tty handling? in any case, under od(1) the
keys give input)

Version-Release number of selected component (if applicable):
bash-3.2-26.fc10.i386

How reproducible:
Always (also on x86_64)

Steps to Reproduce:
1. Go to a tty, log in
2. Type something at bash, try to edit with the arrow keys
3.
  
Actual results:
Nop reaction

Expected results:
Cursor moves, etc

Additional info:
csh (tcsh-6.15-4.fc9.i386) handles <- just fine. On gnome-terminal the arrow
keys work OKin bash.
Comment 1 Roman Rakus 2008-06-24 08:24:26 EDT
I have just done fresh install of rawhide. And I can't reproduce it. And I think
it has nothing to do with bash.

Note You need to log in before you can comment on or make changes to this bug.