Bug 452380 - rotated text is displayed incorrectly
rotated text is displayed incorrectly
Status: CLOSED DUPLICATE of bug 451485
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-21 13:32 EDT by Joe Smith
Modified: 2008-06-22 16:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-22 16:33:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample ODF text document (7.87 KB, application/vnd.oasis.opendocument.text)
2008-06-21 13:32 EDT, Joe Smith
no flags Details
Screenshot showing incorrect text display (11.45 KB, image/png)
2008-06-21 13:34 EDT, Joe Smith
no flags Details

  None (edit)
Description Joe Smith 2008-06-21 13:32:43 EDT
Description of problem:
Text in vertical orientation is displayed incorrectly, with parts of the text
rotated and other parts normal.

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.4.1-17.3.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Open the attached document
2. Rotate /both/ text boxes to 90 degrees: Rt-click > Position and Size >
Rotation > Rotation Angle = 90
3. One text box will rotate correctly, one incorrectly, as shown in the attached
screenshot.
  
Actual results:
Jumbled text display

Expected results:
Correctly rotated text

Additional info:
The display is incorrect in File > Page Preview as well.
Printing or export to PDF shows the correct rendering.

Same problem affects rotated text in tables (also shown in screenshot).

The order of the effect is not consistent: it seems that only one rotated item
will work and others all fail, but it's not always the first item. I don't see a
clear pattern in the order.

OO.org-packaged 2.4.1 on the same system does not have this problem.
Comment 1 Joe Smith 2008-06-21 13:32:43 EDT
Created attachment 309977 [details]
Sample ODF text document
Comment 2 Joe Smith 2008-06-21 13:34:02 EDT
Created attachment 309978 [details]
Screenshot showing incorrect text display
Comment 3 Caolan McNamara 2008-06-22 16:33:15 EDT

*** This bug has been marked as a duplicate of 451485 ***

Note You need to log in before you can comment on or make changes to this bug.