Bug 452421 - EPG and OSD broken in kaffeine-0.8.6
EPG and OSD broken in kaffeine-0.8.6
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kaffeine (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
http://kaffeine.kde.org/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-22 14:08 EDT by Jussi Torhonen
Modified: 2009-02-24 15:56 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.8.7-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 15:53:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kaffeine.spec for rebuilding kaffeine-0.8.7-2.fc10.src.rpm with kaffeine-0.8.7-epg.patch (11.18 KB, application/octet-stream)
2008-08-30 10:58 EDT, Jussi Torhonen
no flags Details
kaffeine-0.8.7-epg.patch (508 bytes, patch)
2008-08-30 10:59 EDT, Jussi Torhonen
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 158943 None None None Never

  None (edit)
Description Jussi Torhonen 2008-06-22 14:08:42 EDT
Description of problem:


Version-Release number of selected component (if applicable):
kaffeine-0.8.6-4.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 9
2. Install kaffeine
3. Scan channels and check EPG and OSD availability
  
Actual results:
Not working

Expected results:
Should work as it did till Fedora 8 and kaffeine-0-8.5

Additional info:
In Fedora 8, kaffeine-0.8.5 works, but kaffeine-0-8.6 does not. Fedora 9 ships
with kaffeine-0.8.6 and EPG + OSD features are not working.

See workaround at
http://bugs.kde.org/show_bug.cgi?id=158943#c22
Comment 1 Steven M. Parrish 2008-08-29 16:46:19 EDT
Here is the fix.  Just need to create a patch and get it applied. 

Ok, the problem is NID==0. As a workaround, edit the file kaffeine/src/input/dvb/plugins/epg/kaffeinedvbevents.cpp and comment out lines 174 to 177 : 
//if ( nid==0) { 
// mutex.unlock(); 
// return 0; 
//}
Comment 2 Jussi Torhonen 2008-08-30 10:58:32 EDT
Created attachment 315422 [details]
kaffeine.spec for rebuilding kaffeine-0.8.7-2.fc10.src.rpm with kaffeine-0.8.7-epg.patch

rpm -ba kaffeine.spec
Comment 3 Jussi Torhonen 2008-08-30 10:59:48 EDT
Created attachment 315423 [details]
kaffeine-0.8.7-epg.patch

kaffeine-0.8.7-epg.patch for kaffeine-0.8.7-2.fc10.src.rpm
Comment 4 Jussi Torhonen 2008-08-30 11:00:39 EDT
Thanks Steven. Works for me!
Comment 5 Steven M. Parrish 2009-02-06 12:02:04 EST
Rex, did this patch ever get applied.  I checked and dont see it, but maybe I'm blind.
Comment 6 Rex Dieter 2009-02-06 12:12:43 EST
Hmm... seems the bz mail got dropped somewhere, I don't recall seeing any of these comments.

I'll take a look at integrating the patch now, sorry for the delay.
Comment 7 Fedora Update System 2009-02-07 17:25:00 EST
kaffeine-0.8.7-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update kaffeine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-1499
Comment 8 Fedora Update System 2009-02-24 15:53:15 EST
kaffeine-0.8.7-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2009-02-24 15:56:46 EST
kaffeine-0.8.7-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.